blob: 90e28340c66e2348ff32f349698ee78f86f16ef5 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Filesystem and hardware benchmark and stress tool"
2DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \
3stress/hardware verification. It has support for a number of I/O engines, \
4I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \
5and much more. It can work on block devices as well as files. fio accepts \
6job descriptions in a simple-to-understand text format. Several example job \
7files are included. fio displays all sorts of I/O performance information."
8HOMEPAGE = "http://freecode.com/projects/fio"
9SECTION = "console/tests"
10LICENSE = "GPL-2.0-only"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
13DEPENDS = "libaio zlib coreutils-native"
14DEPENDS += "${@bb.utils.contains('MACHINE_FEATURES', 'pmem', 'pmdk', '', d)}"
15RDEPENDS:${PN} = "python3-core bash"
16
17PACKAGECONFIG_NUMA = "numa"
18# ARM does not currently support NUMA
19PACKAGECONFIG_NUMA:arm = ""
20PACKAGECONFIG_NUMA:armeb = ""
21
22PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}"
23PACKAGECONFIG[numa] = ",--disable-numa,numactl"
24
Andrew Geissler87f5cff2022-09-30 13:13:31 -050025SRCREV = "db7fc8d864dc4fb607a0379333a0db60431bd649"
26SRC_URI = "git://git.kernel.dk/fio.git;branch=master"
Patrick Williams92b42cb2022-09-03 06:53:57 -050027
28S = "${WORKDIR}/git"
29
30# avoids build breaks when using no-static-libs.inc
31DISABLE_STATIC = ""
32
33EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'"
34EXTRA_OECONF = "${@bb.utils.contains('MACHINE_FEATURES', 'x86', '--disable-optimizations', '', d)}"
35
36do_configure() {
37 ./configure ${EXTRA_OECONF}
38}
39
40do_install() {
41 oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir}
42 install -d ${D}/${docdir}/${PN}
43 cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/
44}