blob: a93ddc823740e41e20c606d14b3b407388ab4e03 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Linux Kernel Crypto API User Space Interface Library"
2HOMEPAGE = "http://www.chronox.de/libkcapi.html"
3LICENSE = "BSD | GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d0421cf231423bda10cea691b613e866"
5
6DEPENDS = "libtool"
7
8S = "${WORKDIR}/git"
9# Use v1.1.3 with changes on top for building in OE
10SRCREV = "1c736c43eb71fbb5640d00efaf34a1edf1972c49"
11PV = "1.1.3+git${SRCPV}"
12SRC_URI = " \
13 git://github.com/smuellerDD/libkcapi.git \
14"
15
16inherit autotools
17
18PACKAGECONFIG ??= ""
19PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,"
20PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,,"
21
22do_install_append() {
23 # bindir contains testapp and apps. However it is always created, even
24 # when no binaries are installed (empty bin_PROGRAMS in Makefile.am),
25 rmdir --ignore-fail-on-non-empty ${D}${bindir}
26}
27
28CPPFLAGS_append_libc-musl_toolchain-clang = " -Wno-error=sign-compare"