blob: 5dcae98b1f09d184dd662d47f1dff12bc38cc109 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Simple top-like I/O monitor"
2DESCRIPTION = "iotop does for I/O usage what top(1) does for CPU usage. \
3 It watches I/O usage information output by the Linux kernel and displays \
4 a table of current I/O usage by processes on the system."
5HOMEPAGE = "http://guichaz.free.fr/iotop/"
6
7
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
10
11SRC_URI = "http://guichaz.free.fr/iotop/files/${BP}.tar.bz2"
12SRC_URI[md5sum] = "5ef9456b26d7694abf3101a72e1e0d1d"
13SRC_URI[sha256sum] = "3adea2a24eda49bbbaeb4e6ed2042355b441dbd7161e883067a02bfc8dcef75b"
14
15inherit distutils
16
17do_install_append() {
18 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo || true
19 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py || true
20}
21
22RDEPENDS_${PN} = "python-curses python-textutils \
23 python-codecs python-ctypes python-pprint \
24 python-shell"