blob: 1a1767e11f212925dea4471e2b2e1942bc451bb8 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Control and monitor storage systems using S.M.A.R.T"
2DESCRIPTION = \
3"The smartmontools package contains two utility programs (smartctl \
4and smartd) to control and monitor storage systems using the Self-\
5Monitoring, Analysis and Reporting Technology System (SMART) built \
6into most modern ATA and SCSI hard disks. In many cases, these \
7utilities will provide advanced warning of disk degradation and failure."
8
9HOMEPAGE = "http://smartmontools.sourceforge.net/"
10SECTION = "console/utils"
11
12LICENSE = "GPLv2"
13LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
14
15SRC_URI = "${SOURCEFORGE_MIRROR}/smartmontools/smartmontools-${PV}.tar.gz \
16 file://initd.smartd \
17 file://smartmontools.default \
18 file://smartd.service \
19"
20
21PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'libcap-ng selinux', d)}"
22PACKAGECONFIG[libcap-ng] = "--with-libcap-ng=yes,--with-libcap-ng=no,libcap-ng"
23PACKAGECONFIG[selinux] = "--with-selinux=yes,--with-selinux=no,libselinux"
24
25SRC_URI[md5sum] = "9ae2c6e7131cd2813edcc65cbe5f223f"
26SRC_URI[sha256sum] = "51f43d0fb064fccaf823bbe68cf0d317d0895ff895aa353b3339a3b316a53054"
27
28inherit autotools update-rc.d systemd
29
30SYSTEMD_SERVICE_${PN} = "smartd.service"
31SYSTEMD_AUTO_ENABLE = "disable"
32
33do_install_append () {
34 #install the init.d/smartd
35 install -d ${D}${sysconfdir}/init.d
36 install -p -m 0755 ${WORKDIR}/initd.smartd ${D}${sysconfdir}/init.d/smartd
37 install -d ${D}${sysconfdir}/default
38 install -p -m 0644 ${WORKDIR}/smartmontools.default ${D}${sysconfdir}/default/smartmontools
39
40 #install systemd service file
41 install -d ${D}${systemd_unitdir}/system
42 install -m 0644 ${WORKDIR}/smartd.service ${D}${systemd_unitdir}/system
43 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
44 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
45 -e 's,@SBINDIR@,${sbindir},g' \
46 ${D}${systemd_unitdir}/system/smartd.service
47}
48
49INITSCRIPT_NAME = "smartd"
50INITSCRIPT_PARAMS = "start 60 2 3 4 5 . stop 60 0 1 6 ."
51
52RDEPENDS_${PN} += "mailx"