blob: 0cc4f6370fa3dafc753a90ceffa72778efeb3143 [file] [log] [blame]
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +05301SUMMARY = "Command line utility to extend hash of arbitrary data into a TPMs PCR."
2HOMEPAGE = "https://github.com/flihp/pcr-extend"
3SECTION = "security/tpm"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7DEPENDS = "libtspi"
8
9PV = "0.1+git${SRCPV}"
10SRCREV = "c02ad8f628b3d99f6d4c087b402fe31a40ee6316"
11
12SRC_URI = "git://github.com/flihp/pcr-extend.git "
13
14inherit autotools
15
16S = "${WORKDIR}/git"
17
18do_compile() {
19 oe_runmake -C ${S}/src
20}
21
22do_install() {
23 install -d ${D}${bindir}
24 oe_runmake -C ${S}/src DESTDIR="${D}" install
25}