blob: 2ead8fa19ec1f57a98098794402147e258ac63db [file] [log] [blame]
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +05301SUMMARY = "Linux Key Management Utilities"
2DESCRIPTION = "\
3 Utilities to control the kernel key management facility and to provide \
4 a mechanism by which the kernel call back to userspace to get a key \
5 instantiated. \
6 "
7HOMEPAGE = "http://people.redhat.com/dhowells/keyutils"
8SECTION = "base"
9
10LICENSE = "LGPLv2.1+ & GPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://LICENCE.GPL;md5=5f6e72824f5da505c1f4a7197f004b45 \
13 file://LICENCE.LGPL;md5=7d1cacaa3ea752b72ea5e525df54a21f"
14
15
16inherit siteinfo ptest
17
18SRC_URI = "http://people.redhat.com/dhowells/keyutils/${BP}.tar.bz2 \
19 file://keyutils-use-relative-path-for-link.patch \
20 file://keyutils-test-fix-output-format.patch \
21 file://keyutils-fix-error-report-by-adding-default-message.patch \
22 file://run-ptest \
23 "
24
25SRC_URI[md5sum] = "3771676319bc7b84b1549b5c63ff5243"
26SRC_URI[sha256sum] = "115c3deae7f181778fd0e0ffaa2dad1bf1fe2f5677cf2e0e348cdb7a1c93afb6"
27
28EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} -Wall' \
29 NO_ARLIB=1 \
30 LIBDIR=${base_libdir} \
31 USRLIBDIR=${base_libdir} \
32 BUILDFOR=${SITEINFO_BITS}-bit \
33 NO_GLIBC_KEYERR=1 \
34 "
35
36do_install () {
37 oe_runmake DESTDIR=${D} install
38}
39
40do_install_ptest () {
41 cp -r ${S}/tests ${D}${PTEST_PATH}/
42 sed -i -e 's/OSDIST=Unknown/OSDIST=${DISTRO}/' ${D}${PTEST_PATH}/tests/prepare.inc.sh
43}
44
45RDEPENDS_${PN}-ptest += "glibc-utils"