blob: 84a02586bedcb832ffab30ccd9d4d108679194fb [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001require rsync.inc
2
3SRC_URI += "file://makefile-no-rebuild.patch"
4
5SRC_URI[md5sum] = "1581a588fde9d89f6bc6201e8129afaf"
6SRC_URI[sha256sum] = "55cc554efec5fdaad70de921cd5a5eeb6c29a95524c715f3bbf849235b0800c0"
7
8# GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0)
9LICENSE = "GPLv3+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
11
12PACKAGECONFIG ??= "acl attr \
13 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
14"
15PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
16PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
17
18# By default, if crosscompiling, rsync disables a number of
19# capabilities, hardlinking symlinks and special files (i.e. devices)
20CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
21
22# rsync 3.0 uses configure.sh instead of configure, and
23# makefile checks the existence of configure.sh
24do_configure_prepend () {
25 rm -f ${S}/configure ${S}/configure.sh
26}
27
28do_configure_append () {
29 cp -f ${S}/configure ${S}/configure.sh
30}
31
32BBCLASSEXTEND = "native"