blob: deadd62c6574e054888a48dffbec58a354c5e669 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001LICENSE = "GPLv3+"
2LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
3
4require diffutils.inc
5
6SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.xz \
7 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
8 file://run-ptest \
9"
10SRC_URI_append_libc-glibc = " file://0001-explicitly-disable-replacing-getopt.patch"
11
12SRC_URI[md5sum] = "07cf286672ced26fba54cd0313bdc071"
13SRC_URI[sha256sum] = "d621e8bdd4b573918c8145f7ae61817d1be9deb4c8d2328a65cea8e11d783bd6"
14
15EXTRA_OECONF += "ac_cv_path_PR_PROGRAM=${bindir}/pr --without-libsigsegv-prefix"
16
17# Fix "Argument list too long" error when len(TMPDIR) = 410
18acpaths = "-I ./m4"
19
20inherit ptest
21
22do_install_ptest() {
23 t=${D}${PTEST_PATH}
24 install -D ${S}/build-aux/test-driver $t/build-aux/test-driver
25 cp -r ${S}/tests $t/
26 install ${B}/tests/Makefile $t/tests/
27 sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
28 -e 's|${DEBUG_PREFIX_MAP}||g' \
29 -e 's:${HOSTTOOLS_DIR}/::g' \
30 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
31 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
32 -e 's|^Makefile:|_Makefile:|' \
33 -e 's|bash|sh|' \
34 -e 's|^top_srcdir = \(.*\)|top_srcdir = ..\/|' \
35 -e 's|^srcdir = \(.*\)|srcdir = .|' \
36 -e 's|"`$(built_programs)`"|diff|' \
37 -e 's|gawk|awk|g' \
38 -i $t/tests/Makefile
39}