blob: 9afb3de217e39efc4b9dab9e62c5839ad64d6621 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require cryptodev.inc
2
3SUMMARY = "A test suite for /dev/crypto device driver"
4
5DEPENDS += "openssl10"
6
7SRC_URI += " \
8file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
9"
10
11EXTRA_OEMAKE='KERNEL_DIR="${STAGING_EXECPREFIXDIR}" PREFIX="${D}"'
12
13do_compile() {
14 oe_runmake testprogs
15}
16
17do_install() {
18 oe_runmake install_tests
19}
20
21FILES_${PN} = "${bindir}/*"