blob: 0bf48ace6b9361e28448af4d4f400914c7a3dbb0 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Framebuffer image and doc viewer tools"
2DESCRIPTION = "The fbida project contains a few applications for viewing and editing images, \
3 with the main focus being photos."
4HOMEPAGE = "http://linux.bytesex.org/fbida/"
5AUTHOR = "Gerd Hoffmann"
6SECTION = "utils"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
10
11DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif"
12
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013SRC_URI = "https://www.kraxel.org/releases/fbida/fbida-${PV}.tar.gz \
14 file://0001-Avoid-using-host-path.patch \
15 file://fix-preprocessor.patch \
16 file://support-jpeg-turbo.patch \
17 file://use-jpeg-turbo.patch \
18 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050019SRC_URI[md5sum] = "09460b964b58c2e39b665498eca29018"
20SRC_URI[sha256sum] = "7a5a3aac61b40a6a2bbf716d270a46e2f8e8d5c97e314e927d41398a4d0b6cb6"
21
22B = "${WORKDIR}/build"
23
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024inherit pkgconfig
25
Patrick Williamsb48b7b42016-08-17 15:04:38 -050026EXTRA_OEMAKE = "STRIP= 'srcdir=${S}' -f ${S}/GNUmakefile"
27
28PACKAGECONFIG ??= "gif png curl"
29PACKAGECONFIG[curl] = ",,curl"
30PACKAGECONFIG[gif] = ",,giflib"
31PACKAGECONFIG[png] = ",,libpng"
32PACKAGECONFIG[tiff] = ",,tiff"
33PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif"
34PACKAGECONFIG[webp] = ",,libwebp"
35PACKAGECONFIG[lirc] = ",,lirc"
36
37do_compile() {
38 sed -i -e 's# fbgs# \$(srcdir)/fbgs#; s#-Ijpeg#-I\$(srcdir)/jpeg#; s# jpeg/# \$(srcdir)/jpeg/#' ${S}/GNUmakefile
39 sed -i -e 's:/sbin/ldconfig:echo x:' ${S}/mk/Autoconf.mk
Brad Bishop6e60e8b2018-02-01 10:27:11 -050040 sed -i -e 's: cpp: ${CPP}:' ${S}/GNUmakefile
Patrick Williamsb48b7b42016-08-17 15:04:38 -050041
42 # Be sure to respect preferences (force to "no")
43 # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050044 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'curl', d)}" ]; then
Patrick Williamsb48b7b42016-08-17 15:04:38 -050045 sed -i -e '/^HAVE_LIBCURL/s/:=.*$/:= no/' ${S}/GNUmakefile
46 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050047 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'gif', d)}" ]; then
Patrick Williamsb48b7b42016-08-17 15:04:38 -050048 sed -i -e '/^HAVE_LIBGIF/s/:=.*$/:= no/' ${S}/GNUmakefile
49 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050050 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'png', d)}" ]; then
Patrick Williamsb48b7b42016-08-17 15:04:38 -050051 sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile
52 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050053 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'tiff', d)}" ]; then
Patrick Williamsb48b7b42016-08-17 15:04:38 -050054 sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile
55 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050056 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'motif', d)}" ]; then
Patrick Williamsb48b7b42016-08-17 15:04:38 -050057 sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile
58 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050059 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'webp', d)}" ]; then
Patrick Williamsb48b7b42016-08-17 15:04:38 -050060 sed -i -e '/^HAVE_LIBWEBP/s/:=.*$/:= no/' ${S}/GNUmakefile
61 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050062 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'lirc', d)}" ]; then
Patrick Williamsb48b7b42016-08-17 15:04:38 -050063 sed -i -e '/^HAVE_LIBLIRC/s/:=.*$/:= no/' ${S}/GNUmakefile
64 fi
65
66 oe_runmake
67}
68
69do_install() {
70 oe_runmake 'DESTDIR=${D}' install
71}
72
73RDEPENDS_${PN} = "ttf-dejavu-sans-mono bash"