blob: 31f55e35899f9379befdd8c75e6105fa95ea6cd7 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "NVM-Express target user space configuration utility."
2DESCRIPTION = "This package contains the command line interface to the NVMe \
3over Fabrics nvmet in the Linux kernel. It allows configuring the nvmet \
4interactively as well as saving / restoring the configuration to / from a json \
5file."
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=1dece7821bf3fd70fe1309eaa37d52a2"
8
9inherit systemd setuptools3
10
11# nvmet service will start and stop the NVMe Target configuration on boot and
12# shutdown from a saved NVMe Target configuration in the /etc/nvmet/config.json
13# file. This file is not installed by default since the configuration will vary
14# on real systems. Example configuration files are provided by including the
15# nvmetcli-examples package.
16SYSTEMD_SERVICE_${PN} = "nvmet.service"
17
18SYSTEMD_AUTO_ENABLE ?= "disable"
19
20RDEPENDS_${PN} += "python3 python3-six python3-pyparsing python3-configshell-fb"
21
22SRCREV = "0a6b088db2dc2e5de11e6f23f1e890e4b54fee64"
23SRC_URI = "git://git.infradead.org/users/hch/nvmetcli.git;branch=master"
24
25S = "${WORKDIR}/git"
26
27do_install_append() {
28 # Install example configuration scripts.
29 install -d ${D}${datadir}/nvmet
30 cp -fr ${S}/examples ${D}${datadir}/nvmet/
31
32 # Install systemd service file.
33 install -d ${D}${systemd_unitdir}/system
34 cp -fr ${S}/nvmet.service ${D}${systemd_unitdir}/system
35}
36
37# Examples package contains example json files used to configure nvmet.
38PACKAGES += "${PN}-examples"
39FILES_${PN}-examples = "${datadir}/nvmet/examples/*"