blob: 760c2dbce48cb699b24d594d6f31d4a75b3f8a50 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A full-featured and high-performance event loop that is loosely \
2modelled after libevent."
3HOMEPAGE = "http://software.schmorp.de/pkg/libev.html"
4LICENSE = "BSD-2-Clause | GPL-2.0+"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d6ad416afd040c90698edcdf1cbee347"
6
7SRC_URI = "http://dist.schmorp.de/libev/Attic/${BP}.tar.gz"
8SRC_URI[md5sum] = "a3433f23583167081bf4acdd5b01b34f"
9SRC_URI[sha256sum] = "507eb7b8d1015fbec5b935f34ebed15bf346bed04a11ab82b8eee848c4205aea"
10
11inherit autotools
12
13EXTRA_OECONF += "--with-pic"
14
15do_install_append() {
16 # Avoid conflicting with libevent. The provided compatibility layer is
17 # still basic so drop it for now.
18 rm ${D}${includedir}/event.h
19}
20
21BBCLASSEXTEND = "native"