blob: 51f5a4eca153306e4d233135fd7dedf5538daa87 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "F Virtual Window Manager "
2HOMEPAGE = "http://www.fvwm.org/"
3SECTION = "x11/wm"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=f8204787357db6ea518dcc9b6cf08388"
6
7DEPENDS = " \
8 bison-native \
9 flex-native \
10 freetype-native \
11 gettext-native \
12 libxslt-native \
13 fontconfig \
14 libice \
15 libpng \
16 librsvg \
17 libsm \
18 libxau \
19 libxcb \
20 libxcursor \
21 libxdmcp \
22 libxext \
23 libxfixes \
24 libxft \
25 libxinerama \
26 libxml2 \
27 libxrender \
28 libxt \
29 virtual/libx11 \
30 xrandr \
31 zlib \
32"
33
Brad Bishopc342db32019-05-15 21:57:59 -040034SRC_URI = " \
35 git://github.com/fvwmorg/fvwm.git;protocol=https \
36 file://0001-Fix-compilation-for-disabled-gnome.patch \
37"
38
Brad Bishope42b3e32020-01-15 22:08:42 -050039SRCREV = "88eab6dc16da6e5dd25fe97fbb56b96ef0d58657"
Brad Bishopc342db32019-05-15 21:57:59 -040040
41S = "${WORKDIR}/git"
42
Andrew Geissler82c905d2020-04-13 13:39:40 -050043inherit autotools gettext update-alternatives pkgconfig python3native perlnative features_check
Brad Bishopc342db32019-05-15 21:57:59 -040044# depends on virtual/libx11
45REQUIRED_DISTRO_FEATURES = "x11"
46
47ALTERNATIVE_${PN} = "x-window-manager"
48ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/fvwm"
49ALTERNATIVE_PRIORITY[x-window-manager] = "20"
50
51EXTRA_OECONF = " \
52 --disable-bidi \
53 --disable-fontconfigtest \
54 --disable-htmldoc \
55 --disable-imlibtest \
Brad Bishopc342db32019-05-15 21:57:59 -040056 --disable-nls \
57 --disable-perllib \
58 --disable-rsvg \
59 --disable-shape \
60 --disable-sm \
61 --disable-xfttest \
62 --with-imlib-exec-prefix=/nonexistent \
63 --with-imlib-prefix=/nonexistent \
64 --without-ncurses-library \
65 --without-readline-library \
66 --without-rplay-library \
67 --without-stroke-library \
68 --without-termcap-library \
69 --without-xpm-library \
70 ac_cv_func_mkstemp=no \
71 has_safety_mkstemp=yes \
72"
73
74# show the exact commands in the log file
75EXTRA_OEMAKE = " \
76 V=1 \
77"
78
79do_install_append() {
80 install -d -m 0755 ${D}/${sysconfdir}/xdg/fvwm
81 # You can install the config file here
82
83 install -d -m 0755 ${D}/${datadir}/fvwm
84 touch ${D}/${datadir}/fvwm/ConfigFvwmDefaults
85}
86
87# the only needed packages (note: locale packages are automatically generated
88# as well)
89PACKAGES = " \
90 ${PN} \
91 ${PN}-dbg \
92"
93
94# minimal set of binaries
95FILES_${PN} = " \
96 ${bindir}/fvwm \
97 ${bindir}/fvwm-root \
98 ${datadir}/fvwm/ConfigFvwmDefaults \
99"
100
101RDEPENDS_${PN} = " \
102 xuser-account \
103"
104
105# by default a lot of stuff is installed and it's not easy to control what to
106# install, so install everything, but skip the check
107INSANE_SKIP_${PN} = " \
108 installed-vs-shipped \
109"