blob: 9fbfc8b49c9e2791a2eb8493c85202b1d35435ec [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001require ttf.inc
2
3SUMMARY = "Adobe OpenType Pan-CJK font family for Simplified Chinese"
4HOMEPAGE = "https://github.com/adobe-fonts/source-han-sans"
5LICENSE = "OFL-1.1"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=55719faa0112708e946b820b24b14097"
7
8inherit allarch fontcache
9
10# Download tends to break - so - or not?
11#EXCLUDE_FROM_WORLD = "1"
12
13SRC_URI = " \
14 https://github.com/adobe-fonts/source-han-sans/raw/release/SubsetOTF/SourceHanSansCN.zip \
15 file://44-source-han-sans-cn.conf \
16"
17SRC_URI[md5sum] = "d16abc21f6575bb08894efedbed484a2"
18SRC_URI[sha256sum] = "0a0e1d8e52833bc352d454d8242da03b82c0efc41323fb66f7435e5b39734a4f"
19
20S = "${WORKDIR}/SourceHanSansCN"
21
22do_install() {
23 install -d ${D}${sysconfdir}/fonts/conf.d/
24 install -m 0644 ${WORKDIR}/44-source-han-sans-cn.conf ${D}${sysconfdir}/fonts/conf.d/
25
26 install -d ${D}${datadir}/fonts/truetype/
27 find ./ -name '*.otf' -exec install -m 0644 {} ${D}${datadir}/fonts/truetype/ \;
28}
29
30FILES_${PN} = " \
31 ${sysconfdir}/fonts \
32 ${datadir}/fonts \
33"
34