blob: a9ebebeef9fad42b49f2df1e2c4d9aa308aecfec [file] [log] [blame]
Andrew Geissler2ee498a2020-05-29 15:52:06 -05001DESCRIPTION = "Add ANSI colors and decorations to your strings"
2
3LICENSE = "ISC"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=aef5566ac4fede9815eccf124c281317"
5
6SRC_URI[sha256sum] = "99f94f5e3348a0bcd43c82e5fc4414013ccc19d70bd939ad71e0133ce9c372e0"
7
8PYPI_PACKAGE_EXT = "zip"
9
Andrew Geisslerd221e032020-07-10 16:13:21 -050010inherit pypi setuptools3 ptest
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS_${PN}-ptest += " \
17 ${PYTHON_PN}-pytest \
18"
19
20do_install_ptest() {
21 cp -f ${S}/test/test.py ${D}${PTEST_PATH}/
22}
Andrew Geissler2ee498a2020-05-29 15:52:06 -050023
24BBCLASSEXTEND = "native nativesdk"