blob: 3bdb86b453a550c13a4847ed16d318c2b98d875d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Python bindings for DBus AT-SPI2 accessibility"
2DESCRIPTION = "AT-SPI2 is a protocol over DBus, toolkit widgets use to provide content to screen readers such as Orca"
3SECTION = "devel/python"
4HOMEPAGE = "https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=db29218e6ba3794c56df7d4987dc7e4d \
7 file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
8DEPENDS = "python3-dbus-native glib-2.0 dbus-glib libxml2 atk gtk+ python3-pygobject"
9
10SRC_URI = "git://github.com/GNOME/pyatspi2.git;protocol=https;branch=mainline"
11SRCREV = "cc99d68db66174f4499b9b325bc788393b972edd"
12S = "${WORKDIR}/git"
13
14# Same restriction as gtk+
15inherit features_check
16ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
17
18inherit pkgconfig autotools python3native
19
20FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/pyatspi/*"