blob: 6fd42ebf8195c48d6ffb087605e20108adb3fa54 [file] [log] [blame]
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05001SUMMARY = "Python binding to the Networking and Cryptography (NaCl) library"
2DESCRIPTION = "Python binding to the Networking and Cryptography (NaCl) library"
3HOMEPAGE = "https://github.com/pyca/pynacl"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f"
6
7SRC_URI[md5sum] = "8c6c57893327a694c72510fb620e4744"
8SRC_URI[sha256sum] = "54e9a2c849c742006516ad56a88f5c74bf2ce92c9f67435187c3c5953b346505"
9
10PYPI_PACKAGE = "PyNaCl"
11
12inherit pypi setuptools3
13
14DEPENDS += "\
15 ${PYTHON_PN}-wheel-native \
16 ${PYTHON_PN}-cffi-native \
17 libsodium \
18"
19
20RDEPENDS_${PN} = "\
21 ${PYTHON_PN}-six \
22 ${PYTHON_PN}-cffi \
23 libsodium \
24"
25
26do_compile_prepend() {
27 export SODIUM_INSTALL=system
28}
29
30do_install_prepend() {
31 export SODIUM_INSTALL=system
32}