blob: 6914cf920e9f84a401e7a777ace720ec0f5abecc [file] [log] [blame]
Andrew Geisslerd688a012020-09-18 13:36:00 -05001SUMMARY = "Python interface for libsystemd"
2HOMEPAGE = "https://github.com/systemd/python-systemd"
3LICENSE = "LGPLv2.1+"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4fbd65380cdd255951079008b364516c"
5
6PYPI_PACKAGE = "systemd-python"
7DEPENDS += "systemd (<=234)"
8RDEPENDS_${PN} += "systemd ${PYTHON_PN}-syslog ${PYTHON_PN}-logging python3-syslog"
9REQUIRED_DISTRO_FEATURES = "systemd"
10inherit pypi features_check setuptools3
11
12SRC_URI[md5sum] = "5071ea5bcb976186e92a3f5e75df221d"
13SRC_URI[sha256sum] = "fd0e44bf70eadae45aadc292cb0a7eb5b0b6372cd1b391228047d33895db83e7"
14
15# allow for common patches for python- and python3-systemd
16FILESEXTRAPATHS_prepend := "${THISDIR}/python-systemd:"
17
18SRC_URI += "file://endian.patch"
19
20SRC_URI_append_libc-musl = " file://0001-Provide-implementation-of-strndupa-for-musl.patch"