blob: 7a778bdfc81bef69517259fe86d25ff18d2d8f92 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Power manager for the Xfce desktop environment"
2HOMEPAGE = "http://goodies.xfce.org/projects/applications/xfce4-power-manager"
3SECTION = "x11"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
7
8inherit xfce features_check
9
10REQUIRED_DISTRO_FEATURES = "x11"
11
12DEPENDS += "libnotify libxrandr virtual/libx11 libxext xfce4-panel upower libxscrnsaver"
13
Andrew Geissler72956ed2021-01-08 16:11:14 -060014SRC_URI[sha256sum] = "eb9c587c01b502fa45a32e7fc2aba98fa6d8391475133883654f77e562c43bf3"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
16EXTRA_OECONF = " \
17 --enable-network-manager \
18 --enable-panel-plugins \
19"
20
21PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)}"
22PACKAGECONFIG[polkit] = "--enable-polkit, --disable-polkit, polkit"
23
24PACKAGES += "xfce4-powermanager-plugin"
25
26FILES_${PN} += " \
27 ${datadir}/polkit-1 \
28 ${datadir}/metainfo \
29"
30
31FILES_xfce4-powermanager-plugin = " \
32 ${libdir}/xfce4 \
33 ${datadir}/xfce4 \
34"
35
36RDEPENDS_xfce4-powermanager-plugin = "${PN}"
37RDEPENDS_${PN} = "networkmanager ${@bb.utils.contains('DISTRO_FEATURES','systemd','','consolekit',d)}"
38
39# xfce4-brightness-plugin was replaced by xfce4-powermanager-plugin
40RPROVIDES_xfce4-powermanager-plugin += "xfce4-brightness-plugin"
41RREPLACES_xfce4-powermanager-plugin += "xfce4-brightness-plugin"
42RCONFLICTS_xfce4-powermanager-plugin += "xfce4-brightness-plugin"