blob: 0b63716f994933141a895e55a6851e12755ed3f5 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Optimised Inner Loop Runtime Compiler"
2HOMEPAGE = "http://gstreamer.freedesktop.org/modules/orc.html"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "Optimised Inner Loop Runtime Compiler is a Library and set of tools for compiling and executing SIMD assembly language-like programs that operate on arrays of data."
Andrew Geissler82c905d2020-04-13 13:39:40 -05004LICENSE = "BSD-2-Clause & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING;md5=1400bd9d09e8af56b9ec982b3d85797e"
6
7SRC_URI = "http://gstreamer.freedesktop.org/src/orc/orc-${PV}.tar.xz"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06008SRC_URI[sha256sum] = "a66e3d8f2b7e65178d786a01ef61f2a0a0b4d0b8370de7ce134ba73da4af18f0"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10inherit meson pkgconfig gtk-doc
11
12GTKDOC_MESON_OPTION = "gtk_doc"
13GTKDOC_MESON_ENABLE_FLAG = "enabled"
14GTKDOC_MESON_DISABLE_FLAG = "disabled"
15
16BBCLASSEXTEND = "native nativesdk"
17
18PACKAGES =+ "orc-examples"
19PACKAGES_DYNAMIC += "^liborc-.*"
20FILES_orc-examples = "${libdir}/orc/*"
21FILES_${PN} = "${bindir}/*"
22
23python populate_packages_prepend () {
24 libdir = d.expand('${libdir}')
25 do_split_packages(d, libdir, r'^lib(.*)\.so\.*', 'lib%s', 'ORC %s library', extra_depends='', allow_links=True)
26}
27
28do_compile_prepend_class-native () {
29 sed -i -e 's#/tmp#.#g' ${S}/orc/orccodemem.c
30}