blob: 9c2c68c70d543359fb599a9edab52c4a3cb72fca [file] [log] [blame]
Allen.Wang4a0948d2021-12-15 13:41:18 +08001SUMMARY = "Bletchley Motor control"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6inherit obmc-phosphor-systemd
7
8RDEPENDS:${PN} += "bash"
Allen.Wang4a0948d2021-12-15 13:41:18 +08009RDEPENDS:${PN} += "i2c-tools"
Patrick Williamsb068a532022-01-19 10:27:13 -060010RDEPENDS:${PN} += "libgpiod-tools"
Potin Laidc251662022-04-01 11:16:50 +080011RDEPENDS:${PN} += "mdio-util"
Potin Lai501f4c72022-06-13 13:23:57 +080012RDEPENDS:${PN} += "bletchley-common-functions"
Allen.Wang4a0948d2021-12-15 13:41:18 +080013
14S = "${WORKDIR}"
Patrick Williamsb068a532022-01-19 10:27:13 -060015SRC_URI += " \
16 file://motor-ctrl \
17 file://motor-init \
18 file://power-ctrl \
19 "
Allen.Wang4a0948d2021-12-15 13:41:18 +080020
21do_install() {
22 install -d ${D}${sbindir}
23 install -m 0755 ${WORKDIR}/power-ctrl ${D}${sbindir}
24
25 install -d ${D}${libexecdir}
Allen.Wang4a0948d2021-12-15 13:41:18 +080026 install -m 0755 ${WORKDIR}/motor-ctrl ${D}${libexecdir}
Patrick Williamsb068a532022-01-19 10:27:13 -060027 install -m 0755 ${WORKDIR}/motor-init ${D}${libexecdir}
Allen.Wang4a0948d2021-12-15 13:41:18 +080028}
29
Allen.Wang89418182022-01-26 10:54:09 +080030TGT = "${SYSTEMD_DEFAULT_TARGET}"
31MOTOR_INIT_INSTFMT="../motor-init-calibration@.service:${TGT}.wants/motor-init-calibration@{0}.service"
Potin Laiffe5f922022-04-12 14:21:33 +080032PWR_ON_INSTFMT="../host-poweron@.service:obmc-host-startmin@{0}.target.wants/host-poweron@{0}.service"
33PWR_OFF_INSTFMT="../host-poweroff@.service:obmc-host-shutdown@{0}.target.wants/host-poweroff@{0}.service"
Allen.Wang89418182022-01-26 10:54:09 +080034AC_ON_INSTFMT="../host-ac-on@.service:${TGT}.wants/host-ac-on@{0}.service"
Potin Lai016db312022-01-17 22:32:02 +080035AC_OFF_INSTFMT="host-ac-off@.service:host-ac-off@{0}.service"
Allen.Wang4a0948d2021-12-15 13:41:18 +080036
Patrick Williamsb068a532022-01-19 10:27:13 -060037SYSTEMD_SERVICE:${PN} += "motor-init-calibration@.service"
38SYSTEMD_LINK:${PN} += "${@compose_list(d, 'MOTOR_INIT_INSTFMT', 'OBMC_HOST_INSTANCES')}"
Allen.Wang4a0948d2021-12-15 13:41:18 +080039
Patrick Williamsb068a532022-01-19 10:27:13 -060040SYSTEMD_SERVICE:${PN} += "host-poweron@.service"
Allen.Wang4a0948d2021-12-15 13:41:18 +080041SYSTEMD_LINK:${PN} += "${@compose_list(d, 'PWR_ON_INSTFMT', 'OBMC_HOST_INSTANCES')}"
42
Patrick Williamsb068a532022-01-19 10:27:13 -060043SYSTEMD_SERVICE:${PN} += "host-poweroff@.service"
Allen.Wang4a0948d2021-12-15 13:41:18 +080044SYSTEMD_LINK:${PN} += "${@compose_list(d, 'PWR_OFF_INSTFMT', 'OBMC_HOST_INSTANCES')}"
Potin Lai016db312022-01-17 22:32:02 +080045
Patrick Williamsb068a532022-01-19 10:27:13 -060046SYSTEMD_SERVICE:${PN} += "host-ac-on@.service"
47SYSTEMD_LINK:${PN} += "${@compose_list(d, 'AC_ON_INSTFMT', 'OBMC_HOST_INSTANCES')}"
Potin Lai016db312022-01-17 22:32:02 +080048
Patrick Williamsb068a532022-01-19 10:27:13 -060049SYSTEMD_SERVICE:${PN} += "host-ac-off@.service"
Potin Lai016db312022-01-17 22:32:02 +080050SYSTEMD_LINK:${PN} += "${@compose_list(d, 'AC_OFF_INSTFMT', 'OBMC_HOST_INSTANCES')}"
Potin Lai807e2b22022-04-13 11:24:00 +080051
52# Host on requires these chassis on
53START_TMPL_CTRL = "obmc-chassis-poweron@.target"
54START_TGTFMT_CTRL = "obmc-host-startmin@{0}.target"
55START_INSTFMT_CTRL = "obmc-chassis-poweron@{0}.target"
56START_FMT_CTRL = "../${START_TMPL_CTRL}:${START_TGTFMT_CTRL}.requires/${START_INSTFMT_CTRL}"
57SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'START_FMT_CTRL', 'OBMC_HOST_INSTANCES')}"
58
59# Chassis off requires host off
60STOP_TMPL_CTRL = "obmc-host-stop@.target"
61STOP_TGTFMT_CTRL = "obmc-chassis-poweroff@{0}.target"
62STOP_INSTFMT_CTRL = "obmc-host-stop@{0}.target"
63STOP_FMT_CTRL = "../${STOP_TMPL_CTRL}:${STOP_TGTFMT_CTRL}.requires/${STOP_INSTFMT_CTRL}"
64SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'STOP_FMT_CTRL', 'OBMC_HOST_INSTANCES')}"
65
66# Hard power off requires chassis off
67HARD_OFF_TMPL_CTRL = "obmc-chassis-poweroff@.target"
68HARD_OFF_TGTFMT_CTRL = "obmc-chassis-hard-poweroff@{0}.target"
69HARD_OFF_INSTFMT_CTRL = "obmc-chassis-poweroff@{0}.target"
70HARD_OFF_FMT_CTRL = "../${HARD_OFF_TMPL_CTRL}:${HARD_OFF_TGTFMT_CTRL}.requires/${HARD_OFF_INSTFMT_CTRL}"
71SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'HARD_OFF_FMT_CTRL', 'OBMC_HOST_INSTANCES')}"
72
73# Host on unit configurations
74HOST_ON_OVERRIDE_CONF_FMT = "host-poweron.conf:host-poweron@{0}.service.d/host-poweron.conf"
75SYSTEMD_OVERRIDE:${PN}:bletchley += "${@compose_list_zip(d, 'HOST_ON_OVERRIDE_CONF_FMT', 'OBMC_HOST_INSTANCES')}"
76
77# Host off unit configurations
78HOST_OFF_OVERRIDE_CONF_FMT = "host-poweroff.conf:host-poweroff@{0}.service.d/host-poweroff.conf"
79SYSTEMD_OVERRIDE:${PN}:bletchley += "${@compose_list_zip(d, 'HOST_OFF_OVERRIDE_CONF_FMT', 'OBMC_HOST_INSTANCES')}"
80