blob: fa106ea41d5e7603db3d936074e21958f89b12a8 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "libTorrent is a BitTorrent library written in C++ for *nix, \
2with a focus on high performance and good code."
3HOMEPAGE = "http://libtorrent.rakshasa.no/"
4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
6
7DEPENDS = "zlib libsigc++-2.0 openssl cppunit"
8
9SRC_URI = "git://github.com/rakshasa/libtorrent \
10 file://don-t-run-code-while-configuring-package.patch \
11 file://0001-implement-64bit-atomic-for-mips.patch \
12 file://0001-Define-64bit-atomic-helpers-for-ppc-32-bit.patch \
13 "
Brad Bishop868407c2019-11-04 13:24:47 -050014SRCREV = "756f70010779927dc0691e1e722ed433d5d295e1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015
Brad Bishop868407c2019-11-04 13:24:47 -050016PV = "0.13.8"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017
18S = "${WORKDIR}/git"
19
20inherit autotools pkgconfig
21
22EXTRA_OECONF = "--with-zlib=${STAGING_EXECPREFIXDIR}"
23
24do_configure_prepend() {
25 (cd ${S}; ./autogen.sh; cd -)
26}