blob: 2fd5631233960f44572f6358d103294c91c0ba5b [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "network performance measurement tool"
2DESCRIPTION = "nuttcp is a network performance measurement tool intended for use by network \
3and system managers. Its most basic usage is to determine the raw TCP (or UDP) \
4network layer throughput by transferring memory buffers from a source system \
5across an interconnecting network to a destination system, either transferring \
6data for a specified time interval, or alternatively transferring a specified \
7number of bytes."
8HOMEPAGE = "http://www.nuttcp.net/Welcome%20Page.html"
9LICENSE = "GPL-2.0"
10SECTION = "net"
11LIC_FILES_CHKSUM = "file://${BP}.c;beginline=4;endline=30;md5=496a7c0bb83c07ff528d226bf85e05c5"
12
13UPSTREAM_CHECK_URI = "https://www.nuttcp.net/nuttcp/beta/"
14
15SRC_URI = "http://nuttcp.net/${BPN}/beta/${BP}.c"
16SRC_URI[md5sum] = "d3c92c4d2f261221193c3726c1b9a42f"
17SRC_URI[sha256sum] = "8c5595bcd27c2fd66831be74c390df078cfb1870aa427f2511ac2586d236c8a1"
18
19S = "${WORKDIR}"
20
21do_compile () {
22 ${CC} ${CFLAGS} ${LDFLAGS} -o nuttcp nuttcp-${PV}.c
23}
24
25do_install () {
26 install -d ${D}${bindir}
27 install -m 0755 nuttcp ${D}${bindir}
28}