blob: 815691dfe18c8b46db66696b4a5d9058ad7c1e04 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "TCTI module for use with TSS2 libraries in UEFI environment"
2SECTION = "security/tpm"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=500b2e742befc3da00684d8a1d5fd9da"
5DEPENDS = "libtss2-dev gnu-efi-native gnu-efi pkgconfig"
6
7SRC_URI = "git://github.com/tpm2-software/tpm2-tcti-uefi.git \
8 file://configure_oe_fixup.patch \
9 "
10SRCREV = "131889d12d2c7d8974711d2ebd1032cd32577b7f"
11
12S = "${WORKDIR}/git"
13
14inherit autotools pkgconfig
15
16COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
17EXTRA_OECONF_append = " --with-efi-includedir=${STAGING_INCDIR}/efi --with-efi-lds=${STAGING_LIBDIR_NATIVE}/"
18RDEPENDS_${PN} = "gnu-efi"