blob: bf06a9f49004b51868a0a6e331b379fbfb13b10e [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001# This class is to be inherited by recipes interested in only deploying what is
2# listed in the EXTRA_IMAGEDEPENDS.
3# It is inheriting the image.bbclass to make sure that the
4# image_license.manifest is generated.
5
6IMAGE_FSTYPES = ""
7
8inherit image
9
10IMAGE_FEATURES = ""
11EXTRA_IMAGE_FEATURES = ""
12
13INHIBIT_DEFAULT_DEPS = "1"
14DEPENDS = ""
15RDEPENDS = ""
16RRECOMMENDS = ""
17
18deltask do_prepare_recipe_sysroot
19deltask do_flush_pseudodb
20deltask do_image_qa
21do_rootfs[depends] = ""
22do_rootfs[noexec] = "1"
23do_image[noexec] = "1"
24do_image_complete[noexec] = "1"
25do_build[depends] = ""