blob: 41202b41faf71769c01d50f3b71517dec272bd63 [file] [log] [blame]
Patrick Venture9afb6712018-09-17 17:14:46 -07001SUMMARY = "Google Sys OEM commands"
Patrick Ventureedb61922018-09-21 14:57:58 -07002DESCRIPTION = "Google Sys OEM commands"
Patrick Venture3adb97a2018-09-26 08:42:56 -07003HOMEPAGE = "https://github.com/openbmc/google-ipmi-sys"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture9afb6712018-09-17 17:14:46 -07008
Andrew Geisslerf64c3c02021-06-24 11:00:17 +00009inherit meson pkgconfig systemd
Patrick Venture9afb6712018-09-17 17:14:46 -070010
Andrew Geisslerf64c3c02021-06-24 11:00:17 +000011DEPENDS += " \
12 nlohmann-json \
13 phosphor-dbus-interfaces \
14 phosphor-logging \
15 phosphor-ipmi-host \
16 sdbusplus \
17 systemd \
18 "
Patrick Venture9afb6712018-09-17 17:14:46 -070019
Yuxiao Zhang1e52b832023-12-13 17:38:28 -080020RDEPENDS:${PN} += " \
21 bare-metal-active \
22 "
23
Patrick Venture9afb6712018-09-17 17:14:46 -070024S = "${WORKDIR}/git"
Patrick Williamsbb99d222022-01-24 15:55:09 -060025SRC_URI = "git://github.com/openbmc/google-ipmi-sys;branch=master;protocol=https"
Andrew Geissler24c10da2024-02-05 12:00:07 -060026SRCREV = "8ef497162ffc5eb7db54e2fe2242125253a5516b"
Patrick Venture9afb6712018-09-17 17:14:46 -070027
Willy Tu4dd03ca2021-08-06 09:37:35 -070028FILES:${PN} += "${libdir}/ipmid-providers"
Patrick Venture9afb6712018-09-17 17:14:46 -070029
30SYSTEMD_PACKAGES = "${PN}"
Willy Tu4dd03ca2021-08-06 09:37:35 -070031SYSTEMD_SERVICE:${PN} += " \
Andrew Geisslerf64c3c02021-06-24 11:00:17 +000032 gbmc-host-poweroff.target \
33 gbmc-psu-hardreset.target \
Andrew Geissler1e9d9162022-04-07 20:30:13 +000034 gbmc-psu-hardreset-pre.target \
35 gbmc-psu-hardreset-time.service \
Andrew Geisslerf64c3c02021-06-24 11:00:17 +000036 "
Patrick Venture9afb6712018-09-17 17:14:46 -070037
Andrew Geisslerf64c3c02021-06-24 11:00:17 +000038EXTRA_OEMESON += "-Dtests=disabled"
William A. Kennington IIIa4cdbe62021-06-04 18:13:35 -070039
William A. Kennington IIIcfcec1f2023-10-18 16:11:40 -070040GBMC_NCSI_IPMI_CHANNEL ??= "1"
41
Willy Tu4dd03ca2021-08-06 09:37:35 -070042CXXFLAGS:append:gbmc = '${@"" if not d.getVar("GBMC_NCSI_IF_NAME") else \
William A. Kennington IIIcfcec1f2023-10-18 16:11:40 -070043 " -DNCSI_IPMI_CHANNEL=" + d.getVar("GBMC_NCSI_IPMI_CHANNEL") + " -DNCSI_IF_NAME=" + d.getVar("GBMC_NCSI_IF_NAME")}'