blob: 475ee2f9e30f71dbab93968d2711e35d4ac39411 [file] [log] [blame]
Yuan Yao72b8b7c2018-09-12 14:58:22 +08001SUMMARY = "HXT Rep board wiring"
2DESCRIPTION = "Board wiring information for the HXT Rep system."
3PR = "r1"
4
5inherit allarch
6inherit setuptools
7inherit pythonnative
8inherit obmc-phosphor-license
9
10PROVIDES += "virtual/obmc-inventory-data"
11RPROVIDES_${PN} += "virtual-obmc-inventory-data"
12
13DEPENDS += "python"
14
15S = "${WORKDIR}"
16SRC_URI += "file://Stardragon4800-rep2.py"
17
18python() {
19 machine = d.getVar('MACHINE', True).capitalize() + '.py'
20 d.setVar('_config_in_skeleton', machine)
21}
22
23do_make_setup() {
24 cp ${S}/${_config_in_skeleton} \
25 ${S}/obmc_system_config.py
26 cat <<EOF > ${S}/setup.py
27from distutils.core import setup
28
29setup(name='${BPN}',
30 version='${PR}',
31 py_modules=['obmc_system_config'],
32 )
33EOF
34}
35
36addtask make_setup after do_patch before do_configure
37