blob: c4778ca38acff795852b439c915122146668dd59 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Opensource Implementation of WS-Management"
2DESCRIPTION = "Openwsman is a project intended to provide an open-source \
3implementation of the Web Services Management specipication \
4(WS-Management) and to expose system management information on the \
5Linux operating system using the WS-Management protocol. WS-Management \
6is based on a suite of web services specifications and usage \
7requirements that exposes a set of operations focused on and covers \
8all system management aspects. \
9Openwsman Server and service libraries"
10HOMEPAGE = "http://www.openwsman.org/"
11SECTION = "Applications/System"
12
13DEPENDS = "curl libxml2 openssl libpam"
14
15SRCREV = "feb7ec9b004fcaea0dbe65ce8a1a79cc29dd994c"
16PV = "2.6.3"
17
18SRC_URI = "git://github.com/Openwsman/openwsman.git \
19 file://libssl-is-required-if-eventint-supported.patch \
20 file://openwsmand.service \
21 file://0001-lock.c-Define-PTHREAD_MUTEX_RECURSIVE_NP-if-undefine.patch \
22 "
23
24S = "${WORKDIR}/git"
25
26LICENSE = "BSD"
27LIC_FILES_CHKSUM = "file://COPYING;md5=d4f53d4c6cf73b9d43186ce3be6dd0ba"
28
29inherit systemd cmake pkgconfig pythonnative perlnative
30
31SYSTEMD_SERVICE_${PN} = "openwsmand.service"
32SYSTEMD_AUTO_ENABLE = "disable"
33
34LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', " -fuse-ld=bfd ", '', d)}"
35
36EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \
37 -DBUILD_LIBCIM=NO \
38 -DBUILD_PERL=YES \
39 -DCMAKE_INSTALL_PREFIX=${prefix} \
40 -DLIB=${baselib} \
41 "
42
43do_configure_prepend() {
44 export STAGING_INCDIR=${STAGING_INCDIR}
45 export STAGING_LIBDIR=${STAGING_LIBDIR}
46}
47
48do_install_append() {
49 install -d ${D}/${sysconfdir}/init.d
50 install -m 755 ${B}/etc/init/openwsmand.sh ${D}/${sysconfdir}/init.d/openwsmand
51 ln -sf ${sysconfdir}/init.d/openwsmand ${D}/${sbindir}/rcopenwsmand
52 chmod 755 ${D}/${sysconfdir}/openwsman/owsmangencert.sh
53 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
54 install -d ${D}/${systemd_unitdir}/system
55 install -m 644 ${WORKDIR}/openwsmand.service ${D}/${systemd_unitdir}/system
56
57 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/openwsmand.service
58 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/openwsmand.service
59 sed -i -e 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${systemd_unitdir}/system/openwsmand.service
60 fi
61}
62
63FILES_${PN}-dbg += "${libdir}/openwsman/plugins/.debug/ \
64 ${libdir}/openwsman/authenticators/.debug/ \
65 "
66
67INSANE_SKIP_${PN} = "dev-so"