blob: cd7e27a19d05b6f532e7d82ff1d5d46f44d44e52 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "The GIMP is the GNU Image Manipulation Program"
2HOMEPAGE = "http://www.gimp.org"
3SECTION = "x11/graphics"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7DEPENDS = " \
8 gdk-pixbuf-native \
9 intltool-native \
10 libxslt-native \
11 gtk+ \
12 babl \
13 gegl \
14 jpeg \
15 libpng \
16 libexif \
17 tiff \
18 lcms \
19 poppler \
20 jasper \
21 bzip2 \
22 libgudev \
23 libmng \
24"
25DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)}"
26
27inherit gnome gtk-doc
28
29SRC_URI = "http://ftp.gimp.org/pub/gimp/v2.8/gimp-${PV}.tar.bz2 \
30 file://0001-configure-ac-do-not-check-for-freetype-config.patch \
31 file://bump_Babl-GEGL_versions.patch \
32 file://0003-Fix-use-of-gegl-API.patch \
33 "
34SRC_URI[md5sum] = "7e4fd7a53b1d3c32dff642ab1a94b44d"
35SRC_URI[sha256sum] = "9187a35cc52b110d78124d7b27b68a68ade14a794c2721314bac6134d2a5638a"
36
37EXTRA_OECONF = "--disable-python \
38 --without-webkit \
39 --without-wmf"
40
41do_configure_append() {
42 find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
43 find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
44}
45
46CFLAGS += "-fPIC"
47
48FILES_${PN}-dbg += "${libdir}/gimp/2.0/*/.debug"
49FILES_${PN} += "${datadir}/appdata"