blob: 3a021031ab8c46a651536f7472b21beeb197a170 [file] [log] [blame]
Patrick Williamsd849ec72016-08-17 14:59:38 -05001SUMMARY = "CRIU"
2DESCRIPTION = "Checkpoint/Restore In Userspace, or CRIU, is a software tool for \
3Linux operating system. Using this tool, you can freeze a running application \
4(or part of it) and checkpoint it to a hard drive as a collection of files. \
5You can then use the files to restore and run the application from the point \
6it was frozen at. The distinctive feature of the CRIU project is that it is \
7mainly implemented in user space"
8HOMEPAGE = "http://criu.org"
9SECTION = "console/tools"
10LICENSE = "GPLv2"
11
12EXCLUDE_FROM_WORLD = "1"
13
Patrick Williamse69d2352017-02-23 20:56:04 -060014LIC_FILES_CHKSUM = "file://COPYING;md5=412de458544c1cb6a2b512cd399286e2"
Patrick Williamsd849ec72016-08-17 14:59:38 -050015
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016SRCREV = "a31c1854e10580a09621e539c3ec052b875a8e06"
17PV = "3.4+git${SRCPV}"
Patrick Williamsd849ec72016-08-17 14:59:38 -050018
19SRC_URI = "git://github.com/xemul/criu.git;protocol=git \
Patrick Williamse69d2352017-02-23 20:56:04 -060020 file://0001-criu-Fix-toolchain-hardcode.patch \
21 file://0002-criu-Skip-documentation-install.patch \
22 file://0001-criu-Change-libraries-install-directory.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023 file://lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch \
Patrick Williamse69d2352017-02-23 20:56:04 -060024 "
Patrick Williamsd849ec72016-08-17 14:59:38 -050025
26COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux"
27
Brad Bishopd7bf8c12018-02-25 22:55:05 -050028DEPENDS += "libnl libcap protobuf-c-native protobuf-c util-linux-native libbsd libnet"
29RDEPENDS_${PN} = "bash"
Patrick Williamsd849ec72016-08-17 14:59:38 -050030
31S = "${WORKDIR}/git"
32
33#
34# CRIU just can be built on ARMv7 and ARMv6, so the Makefile check
35# if the ARCH is ARMv7 or ARMv6.
36# ARM BSPs need set CRIU_BUILD_ARCH variable for building CRIU.
37#
Patrick Williamse69d2352017-02-23 20:56:04 -060038EXTRA_OEMAKE_arm += "ARCH=arm UNAME-M=${CRIU_BUILD_ARCH} WERROR=0"
39EXTRA_OEMAKE_x86-64 += "ARCH=x86 WERROR=0"
40EXTRA_OEMAKE_aarch64 += "ARCH=arm64 WERROR=0"
Patrick Williamsd849ec72016-08-17 14:59:38 -050041
42EXTRA_OEMAKE_append += "SBINDIR=${sbindir} LIBDIR=${libdir} INCLUDEDIR=${includedir} PIEGEN=no"
43EXTRA_OEMAKE_append += "LOGROTATEDIR=${sysconfdir} SYSTEMDUNITDIR=${systemd_unitdir}"
44
Patrick Williamse69d2352017-02-23 20:56:04 -060045CFLAGS += "-D__USE_GNU -D_GNU_SOURCE "
46
47CFLAGS += " -I${STAGING_INCDIR} -I${STAGING_INCDIR}/libnl3"
Patrick Williamsd849ec72016-08-17 14:59:38 -050048
49# overide LDFLAGS to allow criu to build without: "x86_64-poky-linux-ld: unrecognized option '-Wl,-O1'"
50export LDFLAGS=""
51
52export BUILD_SYS
53export HOST_SYS
54
55inherit setuptools
56
Patrick Williamse69d2352017-02-23 20:56:04 -060057PACKAGECONFIG ??= ""
58PACKAGECONFIG[selinux] = ",,libselinux"
59
Patrick Williamsd849ec72016-08-17 14:59:38 -050060do_compile_prepend() {
Patrick Williamse69d2352017-02-23 20:56:04 -060061 rm -rf ${S}/images/google/protobuf/descriptor.proto
62 ln -s ${PKG_CONFIG_SYSROOT_DIR}/usr/include/google/protobuf/descriptor.proto ${S}/images/google/protobuf/descriptor.proto
Patrick Williamsd849ec72016-08-17 14:59:38 -050063}
64
65do_compile () {
66 oe_runmake
67}
68
69do_install () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050070 export INSTALL_LIB="${libdir}/${PYTHON_DIR}/site-packages"
Patrick Williamsd849ec72016-08-17 14:59:38 -050071 oe_runmake PREFIX=${exec_prefix} LIBDIR=${libdir} DESTDIR="${D}" install
72}
73
74FILES_${PN} += "${systemd_unitdir}/ \
75 ${libdir}/python2.7/site-packages/ \
76 ${libdir}/pycriu/ \
77 ${libdir}/crit-0.0.1-py2.7.egg-info \
78 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050079
80FILES_${PN}-staticdev += " \
81 ${libexecdir}/compel/std.lib.a \
82 ${libexecdir}/compel/fds.lib.a \
83 "