blob: 1e2ff74f5784392193d4efbc1c38122fc5cc900c [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Extends Python unittest to make testing easier"
2DESCRIPTION = "nose extends the test loading and running features of unittest, \
3making it easier to write, find and run tests."
4SECTION = "devel/python"
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://lgpl.txt;md5=a6f89e2100d9b6cdffcea4f398e37343"
7
8SRC_URI = "https://files.pythonhosted.org/packages/source/n/nose/nose-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "4d3ad0ff07b61373d2cefc89c5d0b20b"
11SRC_URI[sha256sum] = "f1bffef9cbc82628f6e7d7b40d7e255aefaa1adb6a1b1d26c69a8b79e6208a98"
12
13UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/nose/"
14UPSTREAM_CHECK_REGEX = "/nose/(?P<pver>(\d+[\.\-_]*)+)"
15
16S = "${WORKDIR}/nose-${PV}"
17
18inherit setuptools3
19
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020do_install_append() {
21 mv ${D}${bindir}/nosetests ${D}${bindir}/nosetests3
22}
23
Patrick Williamsc0f7c042017-02-23 20:41:17 -060024RDEPENDS_${PN}_class-target = "\
25 python3-unittest \
26 "
27
28BBCLASSEXTEND = "native nativesdk"