blob: 9fac0444415e112cd40855df366056ad291418b1 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "http://www.webkitgtk.org/"
3BUGTRACKER = "http://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
9 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
10 "
11
12SRC_URI = "http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
14 file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
15 file://0001-OptionsGTK.cmake-drop-the-hardcoded-introspection-gt.patch \
16 file://0001-Fix-racy-parallel-build-of-WebKit2-4.0.gir.patch \
17 file://0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch \
18 file://x32_support.patch \
19 file://cross-compile.patch \
20 file://detect-atomics-during-configure.patch \
21 file://0001-WebKitMacros-Append-to-I-and-not-to-isystem.patch \
22 file://0001-Fix-build-with-musl.patch \
Brad Bishop00111322018-04-01 22:23:53 -040023 file://fix-configure-failure-aarch64.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024 "
25
26SRC_URI[md5sum] = "c1a548595135ee75ad3bf2e18ac83112"
27SRC_URI[sha256sum] = "93912cc2f40f12e452be1ca4babdbdaac0ec4f828d441257a6b06c2963bbac3c"
28
29inherit cmake pkgconfig gobject-introspection perlnative distro_features_check upstream-version-is-even gtk-doc
30
31# depends on libxt
32REQUIRED_DISTRO_FEATURES = "x11"
33
34DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libxt libidn libgcrypt \
35 gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \
36 pango icu bison-native gawk intltool-native libwebp \
37 atk udev harfbuzz jpeg libpng pulseaudio librsvg libtheora libvorbis libxcomposite libxtst \
38 ruby-native libnotify gstreamer1.0-plugins-bad \
39 gettext-native glib-2.0 glib-2.0-native libtasn1 \
40 "
41
42PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'wayland' ,d)} \
43 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'webgl opengl', '' ,d)} \
44 enchant \
45 libsecret \
46 "
47
48PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland"
49PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11"
50PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
51PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant"
52PACKAGECONFIG[gtk2] = "-DENABLE_PLUGIN_PROCESS_GTK2=ON,-DENABLE_PLUGIN_PROCESS_GTK2=OFF,gtk+"
53PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
54PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
55PACKAGECONFIG[opengl] = "-DENABLE_OPENGL=ON,-DENABLE_OPENGL=OFF,virtual/libgl"
56PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret"
57PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
58
59EXTRA_OECMAKE = " \
60 -DPORT=GTK \
61 -DCMAKE_BUILD_TYPE=Release \
62 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
63 ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '-DENABLE_GTKDOC=ON', '-DENABLE_GTKDOC=OFF', d)} \
64 -DENABLE_MINIBROWSER=ON \
65 -DPYTHON_EXECUTABLE=`which python` \
66 "
67
68# GL/GLES header clash: both define the same thing, differently, on 32 bit x86
69EXTRA_OECMAKE_append_x86 = " -DUSE_GSTREAMER_GL=OFF "
70EXTRA_OECMAKE_append_x86-x32 = " -DUSE_GSTREAMER_GL=OFF "
71
72# Javascript JIT is not supported on powerpc
73EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
74EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
75
76# ARM JIT code does not build on ARMv4/5/6 anymore
77EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
78EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
79EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF "
80
81# binutils 2.25.1 has a bug on aarch64:
82# https://sourceware.org/bugzilla/show_bug.cgi?id=18430
83EXTRA_OECMAKE_append_aarch64 = " -DUSE_LD_GOLD=OFF "
84EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF "
85EXTRA_OECMAKE_append_powerpc = " -DUSE_LD_GOLD=OFF "
86EXTRA_OECMAKE_append_toolchain-clang = " -DUSE_LD_GOLD=OFF "
87
88EXTRA_OECMAKE_append_aarch64 = " -DWTF_CPU_ARM64_CORTEXA53=ON"
89
90# JIT not supported on MIPS either
91EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF "
92
93# JIT not supported on X32
94# An attempt was made to upstream JIT support for x32 in
95# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
96# unresolved due to limited X32 adoption.
97EXTRA_OECMAKE_append_x86-x32 = " -DENABLE_JIT=OFF "
98
99SECURITY_CFLAGS_remove_aarch64 = "-fpie"
100SECURITY_CFLAGS_append_aarch64 = " -fPIE"
101
102FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
103
104RRECOMMENDS_${PN} += "ca-certificates shared-mime-info"
105
106# http://errors.yoctoproject.org/Errors/Details/20370/
107ARM_INSTRUCTION_SET_armv4 = "arm"
108ARM_INSTRUCTION_SET_armv5 = "arm"
109ARM_INSTRUCTION_SET_armv6 = "arm"
110
111# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
112# https://bugs.webkit.org/show_bug.cgi?id=159880
113# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
114# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
115ARM_INSTRUCTION_SET_armv7a = "thumb"
116ARM_INSTRUCTION_SET_armv7r = "thumb"
117ARM_INSTRUCTION_SET_armv7ve = "thumb"
118
119# qemu: uncaught target signal 11 (Segmentation fault) - core dumped
120# Segmentation fault
121GI_DATA_ENABLED_armv7a = "False"
122GI_DATA_ENABLED_armv7ve = "False"