blob: 0eff00cc2cc62fddd67f16b48d04a2f5a650b26b [file] [log] [blame]
Brad Bishop5f9be072016-06-27 14:53:52 -04001SUMMARY = "OpenBMC org.openbmc.control.Chassis example implementation"
2DESCRIPTION = "An example implementation of the org.openbmc.control.Chassis DBUS API."
3PR = "r1"
4
5inherit skeleton-python
Brad Bishop1d525fa2016-08-17 20:27:37 -04006inherit obmc-phosphor-dbus-service
Brad Bishop5f9be072016-06-27 14:53:52 -04007
8RDEPENDS_${PN} += "\
9 python-dbus \
10 python-pygobject \
11 python-netclient \
12 pyphosphor \
13 "
14
15SKELETON_DIR = "pychassisctl"
Brad Bishop1d525fa2016-08-17 20:27:37 -040016
17FMT = "org.openbmc.control.Chassis@{0}.service"
18DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"