blob: f38167f1ad090f325d31ead95ac738861f5a19fd [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Package manager forked from Yum, using libsolv as a dependency resolver"
Brad Bishopf3f93bb2019-10-16 14:33:32 -04002DESCRIPTION = "Software package manager that installs, updates, and removes \
3packages on RPM-based Linux distributions. It automatically computes \
4dependencies and determines the actions required to install packages."
Brad Bishopc342db32019-05-15 21:57:59 -04005LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://PACKAGE-LICENSING;md5=4a0548e303dbc77f067335b4d688e745 \
8 "
9
10SRC_URI = "git://github.com/rpm-software-management/dnf.git \
11 file://0001-Corretly-install-tmpfiles.d-configuration.patch \
12 file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \
13 file://0005-Do-not-prepend-installroot-to-logdir.patch \
14 file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
15 file://0030-Run-python-scripts-using-env.patch \
16 "
17
18SRCREV = "9947306a55271b8b7c9e2b6e3b7d582885b6045d"
19UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
20
21S = "${WORKDIR}/git"
22
23inherit cmake gettext bash-completion distutils3-base systemd
24
25DEPENDS += "libdnf librepo libcomps python3-iniparse"
26
27# manpages generation requires http://www.sphinx-doc.org/
28EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
29
30BBCLASSEXTEND = "native nativesdk"
31
32RDEPENDS_${PN} += " \
33 python3-core \
34 python3-codecs \
35 python3-netclient \
36 python3-email \
37 python3-threading \
38 python3-distutils \
39 python3-logging \
40 python3-fcntl \
41 librepo \
42 python3-shell \
43 libcomps \
44 libdnf \
45 python3-sqlite3 \
46 python3-compression \
47 python3-rpm \
48 python3-iniparse \
49 python3-json \
50 python3-curses \
51 python3-misc \
52 python3-gpg \
53 "
54
55RDEPENDS_${PN}_class-native = ""
56
57RRECOMMENDS_${PN}_class-target += "gnupg"
58
59# Create a symlink called 'dnf' as 'make install' does not do it, but
60# .spec file in dnf source tree does (and then Fedora and dnf documentation
61# says that dnf binary is plain 'dnf').
62do_install_append() {
63 lnr ${D}/${bindir}/dnf-3 ${D}/${bindir}/dnf
64 lnr ${D}/${bindir}/dnf-automatic-3 ${D}/${bindir}/dnf-automatic
65}
66
67# Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in
68do_install_append_class-native() {
69 create_wrapper ${D}/${bindir}/dnf \
70 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
71 RPM_NO_CHROOT_FOR_SCRIPTS=1
72}
73
74do_install_append_class-nativesdk() {
75 create_wrapper ${D}/${bindir}/dnf \
76 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
Brad Bishopf3f93bb2019-10-16 14:33:32 -040077 RPM_NO_CHROOT_FOR_SCRIPTS=1
Brad Bishopc342db32019-05-15 21:57:59 -040078}
79
80SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \
81 dnf-automatic.service dnf-automatic.timer \
82 dnf-automatic-download.service dnf-automatic-download.timer \
83 dnf-automatic-install.service dnf-automatic-install.timer \
84 dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \
85"
86SYSTEMD_AUTO_ENABLE ?= "disable"