blob: 4526eeed3fe6189d1a1e9d1aee6238bfa650f27b [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "Timing analysis tools for suspend/resume/boot"
2DESCRIPTION = "This tool suite is designed to assist kernel and OS developers \
3in optimizing their linux stack's suspend/resume & boot time."
4HOMEPAGE = "https://01.org/pm-graph"
5LICENSE = "GPL-2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
7
Brad Bishopa891d152019-09-13 06:17:45 -04008SRCREV = "cf59527dc24fdd2f314ae4dcaeb3d68a117988f6"
Brad Bishopc8f47122019-06-24 09:36:18 -04009SRC_URI = "git://github.com/intel/pm-graph.git \
Brad Bishop26bdd442019-08-16 17:08:17 -040010 file://0001-Makefile-fix-multilib-build-failure.patch \
Brad Bishopa891d152019-09-13 06:17:45 -040011 file://0001-sleepgraph.py-use-python3.patch \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050012 file://0001-sleepgraph-add-support-for-RT-kernel-ftrace-flags.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040013"
Brad Bishop15ae2502019-06-18 21:44:24 -040014S = "${WORKDIR}/git"
15
Andrew Geissler82c905d2020-04-13 13:39:40 -050016# Apart from the listed RDEPENDS, analyze-suspend depends on some features
17# provided by the kernel. These options are:
18# - CONFIG_PM_DEBUG=y
19# - CONFIG_PM_SLEEP_DEBUG=y
20# - CONFIG_FTRACE=y
21# - CONFIG_FUNCTION_TRACER=y
22# - CONFIG_FUNCTION_GRAPH_TRACER=y
23
Brad Bishop15ae2502019-06-18 21:44:24 -040024COMPATIBLE_HOST='(i.86|x86_64).*'
Brad Bishopc8f47122019-06-24 09:36:18 -040025EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D} BASELIB=${baselib}"
Brad Bishop15ae2502019-06-18 21:44:24 -040026
27do_install() {
28 oe_runmake install
Andrew Geissler82c905d2020-04-13 13:39:40 -050029 install -Dm 0755 ${S}/analyze_suspend.py ${D}${bindir}/analyze_suspend.py
Brad Bishop15ae2502019-06-18 21:44:24 -040030}
31
Brad Bishopa891d152019-09-13 06:17:45 -040032RDEPENDS_${PN} += "python3-core python3-threading python3-datetime python3-compression"
Andrew Geissler82c905d2020-04-13 13:39:40 -050033RPROVIDES_${PN} = "analyze-suspend"
34BBCLASSEXTEND = "native nativesdk"