blob: a64aacabf9fec818ecc6ca6987118460a74ea766 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "mcelog daemon accounts memory and some other errors in various ways."
2DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \
3and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \
4and should run on all Linux systems that need error handling."
5HOMEPAGE = "https://mcelog.org/"
6SECTION = "System Environment/Base"
7
Patrick Williams45852732022-04-02 08:58:32 -05008SRC_URI = "\
9 git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http;;branch=master \
Andrew Geissler9aee5002022-03-30 16:27:02 +000010 file://run-ptest \
Patrick Williams45852732022-04-02 08:58:32 -050011 file://0001-genconfig.py-update-shebang.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +000012"
13
14SRCREV = "4146c9296a0cbd26f1c5e411cb44877f350053bd"
15
16LICENSE = "GPL-2.0-only"
17LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
18
19S = "${WORKDIR}/git"
20
21inherit autotools-brokensep ptest
22
23COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
24
25do_install:append() {
26 install -d ${D}${sysconfdir}/cron.hourly
27 install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
28 sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
29}
30
31do_install_ptest() {
32 install -d ${D}${PTEST_PATH}
33 cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH}
34 sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
35}
36
37RDEPENDS:${PN}-ptest += "make bash mce-inject"