blob: 7f3cc5aeb4d3c5347d208ccc2e54176e4f6cb14d [file] [log] [blame]
Adriana Kobylakb96c7502021-08-06 16:25:30 +00001OBMC_IMAGE_EXTRA_INSTALL:append:ibm-ac-server = " mboxd max31785-msl phosphor-msl-verify liberation-fonts uart-render-controller first-boot-set-hostname"
Andrew Geisslered459912023-02-22 16:50:25 -06002OBMC_IMAGE_EXTRA_INSTALL:remove:witherspoon-tacoma = " uart-render-controller"
Andrew Geissler0c3e5ee2021-12-17 19:30:02 +00003OBMC_IMAGE_EXTRA_INSTALL:append:p10bmc = " mboxd"
Andrew Geisslerd1b5b202021-01-04 12:16:39 -06004
Patrick Williamsc0201c92022-04-18 14:29:31 -05005IMAGE_FEATURES:append = " obmc-dbus-monitor"
6
Andrew Geisslerd1b5b202021-01-04 12:16:39 -06007# remove so things fit in available flash space
Adriana Kobylakb96c7502021-08-06 16:25:30 +00008IMAGE_FEATURES:remove:witherspoon = "obmc-user-mgmt-ldap"
Andrew Geissler3475f832021-08-12 09:09:41 -04009IMAGE_FEATURES:remove:witherspoon = "obmc-telemetry"
Joseph Reynolds68e567f2021-02-24 17:20:01 -060010
Priyanga Ramasamy3b64b4e2022-11-18 15:32:37 +000011# Remove unused rsyslog service in P10BMC
12IMAGE_FEATURES:remove:p10bmc = "obmc-remote-logging-mgmt"
13
Andrew Geissler0f80cda2021-08-31 15:50:20 -050014# Generic IPMI FRU vpd collection not needed on p10bmc
15IMAGE_FEATURES:remove:p10bmc = "obmc-fru-ipmi"
16
Joseph Reynolds68e567f2021-02-24 17:20:01 -060017# Optionally configure IBM service accounts
18#
19# To configure your distro, add the following line to its config:
20# DISTRO_FEATURES += "ibm-service-account-policy"
21#
22# The service account policy is as follows:
23# root - The root account remains present. It is needed for internal
24# accounting purposes and for debugging service access.
25# admin - Provides administrative control over the BMC. The role is
26# SystemAdministrator. Admin users have access to interfaces including:
27# Redfish, REST APIs, Web. No access to the BMC via: the BMC's physical
28# console, SSH to the BMC's command line.
29# IPMI access is not granted by default, but admins can authorize
30# themselves and enable the IPMI service.
31# The admin has access to the host console: ssh -p2200 admin@${bmc}.
32# The admin account does not have a home directory.
33# service - Provides IBM service and support representatives (SSRs, formerly
34# known as customer engineers or CEs) access to the BMC. The role is
35# OemIBMServiceAgent. The service user has full admin access, plus access
36# to BMC interfaces intended only to service the BMC and host, including
37# SSH access to the BMC's command line.
38# The service account is not authorized to IPMI because of the inherent
39# security weakness in the IPMI spec and also because the IPMI
40# implementation was not enhanced to use the ACF support.
41# The service account does not have a home directory. The home directory is
42# set to / (the root directory) to allow dropbear ssh connections.
43
Joseph Reynolds516363e2021-08-04 10:01:42 -050044# Override defaults from meta-phosphor/conf/distro/include/phosphor-defaults.inc
Joseph Reynolds68e567f2021-02-24 17:20:01 -060045
Joseph Reynolds68e567f2021-02-24 17:20:01 -060046#IBM_EXTRA_USERS_PARAMS += " \
Joseph Reynolds356f9e12021-07-23 20:15:32 -050047# usermod -p ${DEFAULT_OPENBMC_PASSWORD} root; \
Joseph Reynolds68e567f2021-02-24 17:20:01 -060048# "
49
50# Add group "wheel" (before adding the "service" account).
51IBM_EXTRA_USERS_PARAMS += " \
52 groupadd wheel; \
53 "
54
55# Add the "admin" account.
56IBM_EXTRA_USERS_PARAMS += " \
57 useradd -M -d / --groups priv-admin,redfish,web -s /sbin/nologin admin; \
Joseph Reynolds356f9e12021-07-23 20:15:32 -050058 usermod -p ${DEFAULT_OPENBMC_PASSWORD} admin; \
Joseph Reynolds68e567f2021-02-24 17:20:01 -060059 "
60
61# Add the "service" account.
62IBM_EXTRA_USERS_PARAMS += " \
63 useradd -M -d / --groups priv-admin,redfish,web,wheel service; \
Joseph Reynolds356f9e12021-07-23 20:15:32 -050064 usermod -p ${DEFAULT_OPENBMC_PASSWORD} service; \
Joseph Reynolds68e567f2021-02-24 17:20:01 -060065 "
66
67# This is recipe specific to ensure it takes effect.
Adriana Kobylakb96c7502021-08-06 16:25:30 +000068EXTRA_USERS_PARAMS:pn-obmc-phosphor-image += "${@bb.utils.contains('DISTRO_FEATURES', 'ibm-service-account-policy', "${IBM_EXTRA_USERS_PARAMS}", '', d)}"
Joseph Reynolds68e567f2021-02-24 17:20:01 -060069
70# The service account needs sudo.
Adriana Kobylakb96c7502021-08-06 16:25:30 +000071IMAGE_INSTALL:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'ibm-service-account-policy', 'sudo', '', d)}"