blob: a61a14af79153dbd5a0b1fec305f7a00166335f6 [file] [log] [blame]
Ed Tanous2c2a1c52018-01-29 10:56:52 -08001LICENSE = "Apache-2.0"
Andrew Geisslere11f5e22021-07-20 18:10:59 +00002LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
Ed Tanous07f48cc2021-02-22 10:49:30 -08003DEPENDS = " \
4 openssl \
5 zlib \
6 boost \
Ed Tanous07f48cc2021-02-22 10:49:30 -08007 libpam \
8 sdbusplus \
9 gtest \
10 nlohmann-json \
11 libtinyxml2 \
Ed Tanousa994d3a2021-06-16 12:44:37 -070012 nghttp2 \
Ed Tanousa443c542021-02-26 13:28:37 -080013 ${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest', '', d)} \
14 ${@bb.utils.contains('PTEST_ENABLED', '1', 'gmock', '', d)} \
Ed Tanous07f48cc2021-02-22 10:49:30 -080015"
Andrew Geissler35364bb2024-02-23 15:50:27 -060016SRCREV = "6b9ac4f23ed00c3905c9b99f1d0831930acdbb1c"
Ed Tanous9936f862022-09-19 09:13:20 -070017PV = "1.0+git${SRCPV}"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080018
Patrick Williams0b73b982023-01-26 10:24:41 -060019SRC_URI = "git://github.com/openbmc/bmcweb.git;branch=master;protocol=https"
Ed Tanous9936f862022-09-19 09:13:20 -070020SRC_URI += " \
21 file://run-ptest \
Ed Tanous07f48cc2021-02-22 10:49:30 -080022"
Adriana Kobylak7e0ff54f2018-12-13 11:01:05 -060023
Ed Tanous9936f862022-09-19 09:13:20 -070024S = "${WORKDIR}/git"
25SYSTEMD_SERVICE:${PN} += "bmcweb.service bmcweb.socket"
Ed Tanousa443c542021-02-26 13:28:37 -080026
Ed Tanous9936f862022-09-19 09:13:20 -070027inherit systemd
28inherit useradd
29inherit pkgconfig meson ptest
Ed Tanous2c2a1c52018-01-29 10:56:52 -080030
Patrick Williams4b5fdfa2024-02-23 09:35:19 -060031PACKAGECONFIG ??= "mutual-tls-auth"
Patrick Williamsa7587522023-06-13 14:43:24 -050032PACKAGECONFIG[insecure-redfish-expand]="-Dinsecure-enable-redfish-query=enabled"
Patrick Williams4b5fdfa2024-02-23 09:35:19 -060033PACKAGECONFIG[mutual-tls-auth]="-Dmutual-tls-auth=enabled,-Dmutual-tls-auth=disabled"
Patrick Williamsa7587522023-06-13 14:43:24 -050034
Ed Tanousa443c542021-02-26 13:28:37 -080035EXTRA_OEMESON = " \
36 --buildtype=minsize \
37 -Dtests=${@bb.utils.contains('PTEST_ENABLED', '1', 'enabled', 'disabled', d)} \
Ed Tanousa443c542021-02-26 13:28:37 -080038"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080039
Ed Tanous9936f862022-09-19 09:13:20 -070040do_install_ptest() {
41 install -d ${D}${PTEST_PATH}/test
42 cp -rf ${B}/*_test ${D}${PTEST_PATH}/test/
43}
Ed Tanous2c2a1c52018-01-29 10:56:52 -080044
Ed Tanous9936f862022-09-19 09:13:20 -070045RDEPENDS:${PN} += " \
46 jsnbd \
Patrick Williams0450a022022-10-07 21:23:47 -050047 phosphor-objmgr \
Ed Tanous9936f862022-09-19 09:13:20 -070048"
49
50FILES:${PN} += "${datadir}/** "
51
52USERADD_PACKAGES = "${PN}"
53# add a user called httpd for the server to assume
54USERADD_PARAM:${PN} = "-r -s /sbin/nologin bmcweb"
55
Ninad Palsule34d21442023-03-09 10:20:38 -060056GROUPADD_PARAM:${PN} = "web; redfish; hostconsole"
Andrew Jeffery224f26f2023-03-10 12:38:57 +103057FULL_OPTIMIZATION:append = " -Os"