Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 1 | SUMMARY = "Chassis Power Control service for Intel based platforms" |
| 2 | DESCRIPTION = "Chassis Power Control service for Intel based platforms" |
Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
Andrew Geissler | 89f2fc8 | 2022-11-02 10:12:51 -0500 | [diff] [blame] | 5 | SRCREV = "fa2b6448a5169b5e981a24ae4ca0c03b80a07149" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 6 | PV = "1.0+git${SRCPV}" |
| 7 | |
| 8 | SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=https;branch=master" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 11 | |
Jason M. Bills | 26f9276 | 2021-10-26 13:58:15 -0700 | [diff] [blame] | 12 | inherit meson systemd pkgconfig |
Vijay Khemka | a5bc17f | 2020-06-12 16:26:47 -0700 | [diff] [blame] | 13 | inherit obmc-phosphor-dbus-service |
Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 14 | |
Andrew Geissler | 9e6f034 | 2021-07-15 06:51:21 +0000 | [diff] [blame] | 15 | def get_service(d): |
| 16 | if(d.getVar('OBMC_HOST_INSTANCES') == '0'): |
| 17 | return "xyz.openbmc_project.Chassis.Control.Power@0.service" |
| 18 | else: |
| 19 | return " ".join(["xyz.openbmc_project.Chassis.Control.Power@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()]) |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 20 | SYSTEMD_SERVICE:${PN} = "${@get_service(d)}" |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 21 | SYSTEMD_SERVICE:${PN} += "chassis-system-reset.service \ |
Vijay Khemka | 6dfddb4 | 2020-05-21 16:52:57 -0700 | [diff] [blame] | 22 | chassis-system-reset.target" |
Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 23 | DEPENDS += " \ |
| 24 | boost \ |
| 25 | i2c-tools \ |
| 26 | libgpiod \ |
Priyatharshan P | 9691eaa | 2020-06-30 19:57:55 +0530 | [diff] [blame] | 27 | nlohmann-json \ |
Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 28 | sdbusplus \ |
| 29 | phosphor-logging \ |
| 30 | " |
Patrick Williams | d61a093 | 2021-12-15 21:28:40 -0600 | [diff] [blame] | 31 | FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.Chassis.Control.Power@.service" |