blob: 232872e75aefce32efdd2f7c9fb62e338e257e1a [file] [log] [blame]
Zhenfei Taicd9f5f02021-04-02 17:03:31 -07001SUMMARY = "Nanopb library"
2DESCRIPTION = "Nanopb - Protocol Buffers for Embedded Systems"
3HOMEPAGE = "https://github.com/nanopb/nanopb"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9db4b73a55a3994384112efcdb37c01f"
7
8inherit cmake python3native
9
10SRC_URI = "git://github.com/nanopb/nanopb"
11SRCREV = "f7e4140a27d9e63517b5d596bc117bd6d5248888"
12S = "${WORKDIR}/git"
13
14DEPENDS = "protobuf-native python3-protobuf"
15
16RDEPENDS_${PN}-generator += "python3 python3-protobuf"
17
18PACKAGES_prepend = "${PN}-generator ${PN}-runtime "
19
20FILES_${PN}-generator = "${libdir}/python* ${bindir}"
21
22FILES_${PN}-runtime = "${libdir}/*.so.*"
23
24BBCLASSEXTEND = "native"