blob: 99af81df9c35f7fdf21cd0728726933845ef2dd9 [file] [log] [blame]
Howard Chiu0eb09a12021-12-09 13:27:04 +08001LICENSE = "Apache-2.0"
2LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
3
Potin Lai807e2b22022-04-13 11:24:00 +08004inherit allarch systemd obmc-phosphor-systemd
Howard Chiu0eb09a12021-12-09 13:27:04 +08005
6RDEPENDS:${PN} += "bash"
7RDEPENDS:${PN} += "libgpiod-tools"
8
9SRC_URI += " \
10 file://bletchley-early-sys-init \
11 file://bletchley-sys-init.service \
12 "
13
14SYSTEMD_PACKAGES = "${PN}"
15SYSTEMD_SERVICE:${PN}:append = " \
16 bletchley-sys-init.service \
17 "
18
19do_install() {
20 install -d ${D}${libexecdir}
21 install -m 0755 ${WORKDIR}/bletchley-early-sys-init ${D}${libexecdir}
22
23 install -d ${D}${systemd_system_unitdir}
24 install -m 0644 ${WORKDIR}/bletchley-sys-init.service ${D}${systemd_system_unitdir}
25}
Potin Lai807e2b22022-04-13 11:24:00 +080026
27SYSTEMD_OVERRIDE:${PN}:bletchley += "bletchley-sys-init.conf:bletchley-sys-init.service.d/bletchley-sys-init.conf"