blob: fdf3b245e8eb0cba35f6785d71874d7fbe0defba [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject"
2DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\
3 data structures, using a DOM-like API. JSON-GLib also offers GObject \
4integration, providing the ability to serialize and deserialize GObject \
5instances to and from JSON data types."
Brad Bishop64c979e2019-11-04 13:55:29 -05006HOMEPAGE = "https://wiki.gnome.org/Projects/JsonGlib"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/json-glib/issues"
Brad Bishop19323692019-04-05 15:28:33 -04008
9LICENSE = "LGPLv2.1"
10LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
11
12DEPENDS = "glib-2.0"
13
14GNOMEBASEBUILDCLASS = "meson"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050015inherit gnomebase lib_package gobject-introspection gtk-doc gettext ptest-gnome manpages upstream-version-is-even
Andrew Geissler6ce62a22020-11-30 19:58:47 -060016GIR_MESON_ENABLE_FLAG = 'enabled'
17GIR_MESON_DISABLE_FLAG = 'disabled'
18GTKDOC_MESON_OPTION = "gtk_doc"
19GTKDOC_MESON_ENABLE_FLAG = 'enabled'
20GTKDOC_MESON_DISABLE_FLAG = 'disabled'
Brad Bishop19323692019-04-05 15:28:33 -040021
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060022SRC_URI += " file://run-ptest"
23SRC_URI[archive.sha256sum] = "a33d66c6d038bda46b910c6c6d59c4e15db014e363dc997a0414c2e07d134f24"
Brad Bishop19323692019-04-05 15:28:33 -040024
Andrew Geissler6ce62a22020-11-30 19:58:47 -060025PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
Brad Bishop19323692019-04-05 15:28:33 -040026PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native xmlto-native"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060027PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false"
Brad Bishop19323692019-04-05 15:28:33 -040028
29BBCLASSEXTEND = "native nativesdk"
30
31# Currently it's not possible to disable gettext in Meson, so we need to force
32# this back on.
33USE_NLS_class-native = "yes"