blob: 2185749998b84496372063879abd7ac2a674152b [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "A PKCS#11 interface for TPM2 hardware"
2DESCRIPTION = "PKCS #11 is a Public-Key Cryptography Standard that defines a standard method to access cryptographic services from tokens/ devices such as hardware security modules (HSM), smart cards, etc. In this project we intend to use a TPM2 device as the cryptographic token."
3SECTION = "security/tpm"
4LICENSE = "BSD-2-Clause"
Brad Bishop26bdd442019-08-16 17:08:17 -04005LIC_FILES_CHKSUM = "file://LICENSE;md5=93645981214b60a02688745c14f93c95"
Brad Bishop19323692019-04-05 15:28:33 -04006
7DEPENDS = "autoconf-archive pkgconfig dstat sqlite3 openssl libtss2-dev tpm2-tools"
8
9SRC_URI = "git://github.com/tpm2-software/tpm2-pkcs11.git \
10 file://bootstrap_fixup.patch \
11 "
12
Brad Bishopa3b01f42019-09-13 06:30:46 -040013SRCREV = "caf20c04651029626466c59d88b36c05cc6ea20b"
Brad Bishop19323692019-04-05 15:28:33 -040014
15S = "${WORKDIR}/git"
16
17inherit autotools-brokensep pkgconfig
18
19do_configure_prepend () {
20 ${S}/bootstrap
21}