blob: 65617fa3be01dd990dfc53d56ec56ff3186403fe [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001HOMEPAGE = "http://www.alumnit.ca/wiki/?WvDial"
2DESCRIPTION = "WvDial is a program that makes it easy to connect your Linux workstation to the Internet."
3
4LICENSE = "LGPLv2"
5LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605"
6
7DEPENDS = "wvstreams"
8RDEPENDS_${PN} = "ppp"
9
10SRC_URI = "http://${BPN}.googlecode.com/files/${BP}.tar.bz2 \
11 file://typo_pon.wvdial.1.patch \
12 "
13
14SRC_URI[md5sum] = "37e9a2d664effe4efd44c0e1a20136de"
15SRC_URI[sha256sum] = "99906d9560cbdbc97e1855e7b0a7169f1e11983be3ac539140423f09debced82"
16
17EXTRA_OEMAKE = ""
18export WVLINK="${LD}"
19
20PARALLEL_MAKE = ""
21
22BUILD_CPPFLAGS += "-I${STAGING_INCDIR}/wvstreams"
23
24do_configure() {
25 sed -i 's/LDFLAGS+=-luniconf/LIBS+=-luniconf/' ${S}/Makefile
26}
27
28do_install() {
29 oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install
30}
Patrick Williamsddad1a12017-02-23 20:36:32 -060031
32PNBLACKLIST[wvdial] ?= "Depends on broken wvstreams"