blob: 96e977c15618c506b591eff0d8b425e9064fe35a [file] [log] [blame]
Andrew Jeffery1b77f28e2018-04-06 14:13:14 +09301SUMMARY = "Phosphor IPMI daemon configuration"
2PR = "r1"
Brad Bishop75f03872018-11-03 09:41:57 -07003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
Andrew Jeffery1b77f28e2018-04-06 14:13:14 +09305
Andrew Jeffery1b77f28e2018-04-06 14:13:14 +09306inherit allarch
7
8SRC_URI = " \
9 file://cipher_list.json \
10 file://dcmi_cap.json \
11 file://dcmi_sensors.json \
12 file://dev_id.json \
13 file://power_reading.json \
AppaRao Puli225e91f2018-06-27 23:40:11 +053014 file://channel_access.json \
15 file://channel_config.json \
Andrew Jeffery1b77f28e2018-04-06 14:13:14 +093016 "
17
18FILES_${PN} = " \
19 ${datadir}/ipmi-providers/cipher_list.json \
20 ${datadir}/ipmi-providers/dcmi_cap.json \
21 ${datadir}/ipmi-providers/dcmi_sensors.json \
22 ${datadir}/ipmi-providers/dev_id.json \
23 ${datadir}/ipmi-providers/power_reading.json \
AppaRao Puli225e91f2018-06-27 23:40:11 +053024 ${datadir}/ipmi-providers/channel_access.json \
25 ${datadir}/ipmi-providers/channel_config.json \
Andrew Jeffery1b77f28e2018-04-06 14:13:14 +093026 "
27
28do_fetch[noexec] = "1"
29do_patch[noexec] = "1"
30do_configure[noexec] = "1"
31do_compile[noexec] = "1"
32
33do_install() {
34 install -d ${D}${datadir}/ipmi-providers
35 install -m 0644 -D ${WORKDIR}/cipher_list.json \
36 ${D}${datadir}/ipmi-providers/cipher_list.json
37 install -m 0644 -D ${WORKDIR}/dcmi_cap.json \
38 ${D}${datadir}/ipmi-providers/dcmi_cap.json
39 install -m 0644 -D ${WORKDIR}/dcmi_sensors.json \
40 ${D}${datadir}/ipmi-providers/dcmi_sensors.json
41 install -m 0644 -D ${WORKDIR}/dev_id.json \
42 ${D}${datadir}/ipmi-providers/dev_id.json
43 install -m 0644 -D ${WORKDIR}/power_reading.json \
44 ${D}${datadir}/ipmi-providers/power_reading.json
AppaRao Puli225e91f2018-06-27 23:40:11 +053045 install -m 0644 -D ${WORKDIR}/channel_access.json \
46 ${D}${datadir}/ipmi-providers/channel_access.json
47 install -m 0644 -D ${WORKDIR}/channel_config.json \
48 ${D}${datadir}/ipmi-providers/channel_config.json
49
Andrew Jeffery1b77f28e2018-04-06 14:13:14 +093050}