blob: 863f924b22bc8e878c34aa21ec3bb6b00c44277d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Tool to produce a statistics based on a diff"
2DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \
3the insertions, deletions, and modifications per-file. It is useful for \
4reviewing large, complex patch files."
5HOMEPAGE = "http://invisible-island.net/diffstat/"
6SECTION = "devel"
7LICENSE = "MIT"
Andrew Geisslerc723b722021-01-08 16:14:09 -06008LIC_FILES_CHKSUM = "file://COPYING;md5=a3d0bb117493e804b0c1a868ddf23321"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \
11 file://run-ptest \
12 file://avoid-check-user-break-cc.patch \
13 file://0001-aclocal.m4-add-missing-header-defines.patch \
14 "
15
16SRC_URI[md5sum] = "b9272ec8af6257103261ec3622692991"
17SRC_URI[sha256sum] = "7eddd53401b99b90bac3f7ebf23dd583d7d99c6106e67a4f1161b7a20110dc6f"
18
Andrew Geissler82c905d2020-04-13 13:39:40 -050019inherit autotools gettext ptest
20
21EXTRA_AUTORECONF += "--exclude=aclocal"
22
23LDFLAGS += "${TOOLCHAIN_OPTIONS}"
24
25do_install_ptest() {
26 cp -r ${S}/testing ${D}${PTEST_PATH}
27}
Andrew Geissler6ce62a22020-11-30 19:58:47 -060028
29BBCLASSEXTEND = "nativesdk"