blob: e055fbed11f8a4da3e14016ba73a36cdfe05e2af [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Linux Kernel Runtime Guard"
2DESCRIPTION="LKRG performs runtime integrity checking of the Linux \
3kernel and detection of security vulnerability exploits against the kernel."
4SECTION = "security"
5HOMEPAGE = "https://www.openwall.com/lkrg/"
6LICENSE = "GPLv2"
7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=5105ead24b08a32954f34cbaa7112432"
9
10DEPENDS = "virtual/kernel elfutils"
11
12SRC_URI = "https://download.openwall.net/pub/projects/lkrg/lkrg-${PV}.tar.gz \
13 file://makefile_cleanup.patch "
14
15SRC_URI[sha256sum] = "c2b501c47089cce3ec3114cef6520b73aa3a098836183186b9bb5e097c99ac27"
16
17S = "${WORKDIR}/lkrg-${PV}"
18
19inherit module kernel-module-split
20
21MAKE_TARGETS = "modules"
22
23MODULE_NAME = "p_lkrg"
24
25module_do_install() {
26 install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
27 install -m 0644 ${MODULE_NAME}.ko \
28 ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
29}
30
31RPROVIDES:${PN} += "kernel-module-lkrg"
32
33COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"