blob: 322158146643d5b112db772ef2e6ed193314daf3 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Client for Microsoft PPTP VPNs"
2DESCRIPTION = "PPTP Client is a Linux, FreeBSD, NetBSD \
3 and OpenBSD client for the proprietary Microsoft Point-to-Point \
4 Tunneling Protocol, PPTP. Allows connection to a PPTP based \
5 Virtual Private Network (VPN) as used by employers and some \
6 cable and ADSL internet service providers."
7HOMEPAGE = "http://pptpclient.sourceforge.net"
8SECTION = "net"
9LICENSE = "GPLv2+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/sourceforge/pptpclient/pptp-${PV}.tar.gz \
13 file://options.pptp \
14 "
15
16SRC_URI[md5sum] = "8d25341352fdae5ad5b36b9f18254908"
17SRC_URI[sha256sum] = "82492db8e487ce73b182ee7f444251d20c44f5c26d6e96c553ec7093aefb5af4"
18
19S = "${WORKDIR}/pptp-${PV}"
20
21EXTRA_OEMAKE = "-e MAKEFLAGS="
22
23do_install() {
24 install -d ${D}${sbindir} ${D}${sysconfdir}/ppp ${D}${mandir}/man8
25 install -m 555 pptp ${D}${sbindir}
26 install -m 644 pptp.8 ${D}${mandir}/man8
27 install -m 644 ${WORKDIR}/options.pptp ${D}${sysconfdir}/ppp
28}
29
30RDEPENDS_${PN} = "ppp"