blob: 9d311608e4add58ce168eef83de4f987c751a1fa [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Library for interacting with ID3 tags"
2SECTION = "libs/multimedia"
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
5DEPENDS = "zlib"
6
7PR = "r1"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/id3lib/id3lib-${PV}.tar.gz;name=archive \
Brad Bishope42b3e32020-01-15 22:08:42 -050010 ${DEBIAN_MIRROR}/main/i/id3lib3.8.3/id3lib3.8.3_3.8.3-16.2.debian.tar.xz;name=patch;subdir=${BP} \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011 file://acdefine.patch \
12"
13SRC_URI[archive.md5sum] = "19f27ddd2dda4b2d26a559a4f0f402a7"
14SRC_URI[archive.sha256sum] = "2749cc3c0cd7280b299518b1ddf5a5bcfe2d1100614519b68702230e26c7d079"
Brad Bishope42b3e32020-01-15 22:08:42 -050015SRC_URI[patch.md5sum] = "997c764d3be11c9a51779d93facf1118"
16SRC_URI[patch.sha256sum] = "ac2ee23ec89ba2af51d2c6dd5b1b6bf9f8a9f813de251bc182941439a4053176"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017
18inherit autotools
Brad Bishope42b3e32020-01-15 22:08:42 -050019
20# Unlike other Debian packages, id3lib*.diff.gz contains another series of
21# patches maintained by quilt. So manually apply them before applying other local
22# patches. Also remove all temp files before leaving, because do_patch() will pop
23# up all previously applied patches in the start
24id3lib_do_patch() {
25 cd ${S}
26 # it's important that we only pop the existing patches when they've
27 # been applied, otherwise quilt will climb the directory tree
28 # and reverse out some completely different set of patches
29 if [ -d ${S}/patches ]; then
30 # whilst this is the default directory, doing it like this
31 # defeats the directory climbing that quilt will otherwise
32 # do; note the directory must exist to defeat this, hence
33 # the test inside which we operate
34 QUILT_PATCHES=${S}/patches quilt pop -a
35 fi
36 if [ -d ${S}/.pc-id3lib ]; then
37 rm -rf ${S}/.pc
38 mv ${S}/.pc-id3lib ${S}/.pc
39 QUILT_PATCHES=${S}/debian/patches quilt pop -a
40 rm -rf ${S}/.pc ${S}/debian
41 fi
42 QUILT_PATCHES=${S}/debian/patches quilt push -a
43 mv ${S}/.pc ${S}/.pc-id3lib
44}
45
46do_unpack[cleandirs] += "${S}"
47
48# We invoke base do_patch at end, to incorporate any local patch
49python do_patch() {
50 bb.build.exec_func('id3lib_do_patch', d)
51 bb.build.exec_func('patch_do_patch', d)
52}