blob: 9fdbbf254c0e71f79a765c6facdb03f3b1c8f2ce [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "A TCP/IP Daemon simplifying the communication with GPS devices"
2SECTION = "console/network"
Brad Bishop26bdd442019-08-16 17:08:17 -04003LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=01764c35ae34d9521944bb6ab312af53"
Brad Bishope42b3e32020-01-15 22:08:42 -05005DEPENDS = "dbus ncurses python python3 pps-tools"
Brad Bishop316dfdd2018-06-25 12:45:53 -04006PROVIDES = "virtual/gpsd"
7
Brad Bishop316dfdd2018-06-25 12:45:53 -04008SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \
9 file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \
Brad Bishop93c3acf2019-10-29 09:48:15 -040010 file://0001-gps_shm_close-Free-privdata.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040011"
Brad Bishop26bdd442019-08-16 17:08:17 -040012SRC_URI[md5sum] = "b3bf88706794eb8e5f2c2543bf7ba87b"
13SRC_URI[sha256sum] = "27dd24d45b2ac69baab7933da2bf6ae5fb0be90130f67e753c110a3477155f39"
Brad Bishop316dfdd2018-06-25 12:45:53 -040014
Brad Bishop26bdd442019-08-16 17:08:17 -040015inherit scons update-rc.d python-dir pythonnative systemd update-alternatives
Brad Bishop316dfdd2018-06-25 12:45:53 -040016
17INITSCRIPT_PACKAGES = "gpsd-conf"
18INITSCRIPT_NAME = "gpsd"
19INITSCRIPT_PARAMS = "defaults 35"
20
21SYSTEMD_OESCONS = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false',d)}"
22
23export STAGING_INCDIR
24export STAGING_LIBDIR
25
Brad Bishope42b3e32020-01-15 22:08:42 -050026PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} usb"
Brad Bishop26bdd442019-08-16 17:08:17 -040027PACKAGECONFIG[bluez] = "bluez='true',bluez='false',bluez5"
Brad Bishop15ae2502019-06-18 21:44:24 -040028PACKAGECONFIG[qt] = "qt='yes' qt_versioned=5,qt='no',qtbase"
Brad Bishope42b3e32020-01-15 22:08:42 -050029PACKAGECONFIG[usb] = "usb='true',usb='false',libusb1"
Brad Bishop316dfdd2018-06-25 12:45:53 -040030EXTRA_OESCONS = " \
31 sysroot=${STAGING_DIR_TARGET} \
32 libQgpsmm='false' \
Brad Bishop26bdd442019-08-16 17:08:17 -040033 debug='false' \
34 nostrip='true' \
Brad Bishop316dfdd2018-06-25 12:45:53 -040035 systemd='${SYSTEMD_OESCONS}' \
36 libdir='${libdir}' \
Brad Bishop26bdd442019-08-16 17:08:17 -040037 manbuild='false' \
Brad Bishop316dfdd2018-06-25 12:45:53 -040038 ${PACKAGECONFIG_CONFARGS} \
39"
40# this cannot be used, because then chrpath is not found and only static lib is built
41# target=${HOST_SYS}
42
43do_compile_prepend() {
44 export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}"
45 export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
46 export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
47 export LINKFLAGS="${LDFLAGS}"
48}
49
50do_install() {
51 export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}"
52 export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
53 export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
54 export LINKFLAGS="${LDFLAGS}"
55
56 export DESTDIR="${D}"
57 # prefix is used for RPATH and DESTDIR/prefix for instalation
Brad Bishop26bdd442019-08-16 17:08:17 -040058 ${STAGING_BINDIR_NATIVE}/scons prefix=${prefix} python_libdir=${libdir} install ${EXTRA_OESCONS} || \
Brad Bishop316dfdd2018-06-25 12:45:53 -040059 bbfatal "scons install execution failed."
60}
61
62do_install_append() {
63 install -d ${D}/${sysconfdir}/init.d
64 install -m 0755 ${S}/packaging/deb/etc_init.d_gpsd ${D}/${sysconfdir}/init.d/gpsd
65 install -d ${D}/${sysconfdir}/default
66 install -m 0644 ${S}/packaging/deb/etc_default_gpsd ${D}/${sysconfdir}/default/gpsd.default
67
68 #support for udev
69 install -d ${D}/${sysconfdir}/udev/rules.d
70 install -m 0644 ${S}/gpsd.rules ${D}/${sysconfdir}/udev/rules.d/
71 install -d ${D}${base_libdir}/udev/
72 install -m 0755 ${S}/gpsd.hotplug ${D}${base_libdir}/udev/
73
74 #support for python
75 install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
76 install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
77
78 #support for systemd
79 install -d ${D}${systemd_unitdir}/system/
80 install -m 0644 ${S}/systemd/${BPN}.service ${D}${systemd_unitdir}/system/${BPN}.service
Brad Bishop26bdd442019-08-16 17:08:17 -040081 sed -i -e 's,/usr/local,/usr,g' ${D}${systemd_unitdir}/system/${BPN}.service
Brad Bishop316dfdd2018-06-25 12:45:53 -040082 install -m 0644 ${S}/systemd/${BPN}ctl@.service ${D}${systemd_unitdir}/system/${BPN}ctl@.service
Brad Bishop26bdd442019-08-16 17:08:17 -040083 sed -i -e 's,/usr/local,/usr,g' ${D}${systemd_unitdir}/system/${BPN}ctl@.service
Brad Bishop316dfdd2018-06-25 12:45:53 -040084 install -m 0644 ${S}/systemd/${BPN}.socket ${D}${systemd_unitdir}/system/${BPN}.socket
85}
86
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080087PACKAGES =+ "libgps libgpsd python-pygps gpsd-udev gpsd-conf gpsd-gpsctl gps-utils"
88
89RPROVIDES_${PN}-dbg += "python-pygps-dbg"
Brad Bishop316dfdd2018-06-25 12:45:53 -040090
91FILES_${PN}-dev += "${libdir}/pkgconfdir/libgpsd.pc ${libdir}/pkgconfdir/libgps.pc \
92 ${libdir}/libQgpsmm.prl"
93
Brad Bishop316dfdd2018-06-25 12:45:53 -040094RDEPENDS_${PN} = "gpsd-gpsctl"
95RRECOMMENDS_${PN} = "gpsd-conf gpsd-udev gpsd-machine-conf"
96
97SUMMARY_gpsd-udev = "udev relevant files to use gpsd hotplugging"
98FILES_gpsd-udev = "${base_libdir}/udev ${sysconfdir}/udev/*"
99RDEPENDS_gpsd-udev += "udev gpsd-conf"
100
101SUMMARY_libgpsd = "C service library used for communicating with gpsd"
102FILES_libgpsd = "${libdir}/libgpsd.so.*"
103
104SUMMARY_libgps = "C service library used for communicating with gpsd"
105FILES_libgps = "${libdir}/libgps.so.*"
106
107SUMMARY_gpsd-conf = "gpsd configuration files and init scripts"
108FILES_gpsd-conf = "${sysconfdir}"
109CONFFILES_gpsd-conf = "${sysconfdir}/default/gpsd.default"
110
111SUMMARY_gpsd-gpsctl = "Tool for tweaking GPS modes"
112FILES_gpsd-gpsctl = "${bindir}/gpsctl"
113
114SUMMARY_gps-utils = "Utils used for simulating, monitoring,... a GPS"
Brad Bishop26bdd442019-08-16 17:08:17 -0400115# Python files are required for gps/fake, required for gpsfake.
116FILES_gps-utils = "${bindir}/* ${libdir}/gps/*.py ${libdir}/gps/*.so"
Brad Bishop316dfdd2018-06-25 12:45:53 -0400117RDEPENDS_gps-utils = "python-pygps"
118
119SUMMARY_python-pygps = "Python bindings to gpsd"
Brad Bishop26bdd442019-08-16 17:08:17 -0400120FILES_python-pygps = "${PYTHON_SITEPACKAGES_DIR}/* ${libdir}/gps/*.py ${libdir}/*.egg-info"
Brad Bishop316dfdd2018-06-25 12:45:53 -0400121RDEPENDS_python-pygps = " \
122 python-core \
123 python-io \
124 python-threading \
125 python-terminal \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400126 gpsd \
127 python-json"
128
129RPROVIDES_${PN} += "${PN}-systemd"
130RREPLACES_${PN} += "${PN}-systemd"
131RCONFLICTS_${PN} += "${PN}-systemd"
132SYSTEMD_SERVICE_${PN} = "${BPN}.socket ${BPN}ctl@.service"
133
134
135ALTERNATIVE_${PN} = "gpsd-defaults"
136ALTERNATIVE_LINK_NAME[gpsd-defaults] = "${sysconfdir}/default/gpsd"
137ALTERNATIVE_TARGET[gpsd-defaults] = "${sysconfdir}/default/gpsd.default"